Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running CentOS 6.3 64bit and DirectAdmin control panel. Currently I have installed Apache Subversion 1.6.19 without any problems.

I have installed expat and expat-devel and neon-devel using yum.

When installing Apache Subversion 1.6.19 this configure command works fine:

./configure --prefix=/usr --with-ssl --with-apxs=/usr/sbin/apxs --with-apr=/usr/bin/apr-config

However when installing Apache Subversion 1.7.7 using the same configure command as above, I get this error after doing commmand "make":

/etc/httpd/lib/libaprutil-1.so: undefined reference to `XML_StopParser'
collect2: ld returned 1 exit status
make: *** [subversion/svnadmin/svnadmin] Error 1

However I found out I can solve that problem by adding this into the configure command:

--with-expat=includes:lib_search_dirs:libs

So it then looks like this:

./configure --prefix=/usr --with-ssl --with-expat=includes:lib_search_dirs:libs --with-apxs=/usr/sbin/apxs --with-apr=/usr/bin/apr-config

However that configure command then give this warning:

configure: WARNING: Expat found amongst libraries used by APR-Util, but Subversion libraries might be needlessly linked against additional unused libraries. It can be avoided by specifying exact location of Expat in argument of --with-expat option.

So I want to solve that. I have experimentet alot, but not been able to figure out how to "specifying exact location of Expat" in configure command, and how to find out what the location should be?

However after a lot of searching I found this: http://subversion.tigris.org/issues/show_bug.cgi?id=3997 - that is a FreeBSD user saying this:

Building Subversion 1.7.x on FreeBSD currently requires a configure flag:

--with-expat=/usr/local/include:/usr/local/lib:expat

As that is the default location of expat on that platform, it would be nice if configure detected it automatically.

However I am not using FreeBSD, I am running CentOS 6.3 64bit. Also remember I said I have installed expat and expat-devel and neon-devel using yum.

However I tried to use the expat/command path posted by the FreeBSD user, and it seems to work, it does not give errors when running configure command, and does not give errors when running "make". This is what I used then:

./configure --prefix=/usr --with-ssl --with-expat=/usr/local/include:/usr/local/lib:expat --with-apxs=/usr/sbin/apxs --with-apr=/usr/bin/apr-config

But this server is a production server, and therfor I need your help to advice if this is also correct to run on a CentOS server? Is the following path in expat command correct on CentOS?:

--with-expat=/usr/local/include:/usr/local/lib:expat

If not, please advice what it should be changed to. Thanks in advance for any confirmation or help on this!


I was wrong, the expat location from FreeBSD does not work on CentOS. This:

./configure --prefix=/usr --with-ssl --with-expat=/usr/local/include:/usr/local/lib:expat --with-apxs=/usr/sbin/apxs --with-apr=/usr/bin/apr-config

Give this error after doing "make":

/etc/httpd/lib/libaprutil-1.so: undefined reference to `XML_StopParser'
collect2: ld returned 1 exit status
make: *** [subversion/svnadmin/svnadmin] Error 1

I give up. I do not find any answer about how to specify the expat loacation in above command for CentOS anywhere on the Internet (been searching for over a week after solution), and have posted for help several places.

share|improve this question
add comment

1 Answer

You have installed the expat-devel package, right?

share|improve this answer
    
Yes, I have installed the expat-devel package. –  ditto Oct 22 '12 at 17:33
    
Then you should be able to ignore the spurious warning. –  Michael Hampton Oct 22 '12 at 17:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.