Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm building a lab network with some old Cisco gear so that I can properly test the deployment of a Read-Only Domain Controller in a vacuum (no connectivity to our production network). Essentially, I'm building a router on a stick - but I want two different networks on two different routers.

Here's my setup:

Cisco MC3800 Router - 10.0/16 (IP address: 10.0.0.1)
Cisco 2600 Router - 10.1/16 (IP address: 10.1.0.1)

Now here's where it gets funky:

Cisco 2950 Switch

FA0/1 - Trunk Vlan 10 (10.0.0.2 - goes to router 10.0.0.1)
FA0/2 - Trunk Vlan 20 (10.1.0.2 - goes to router 10.1.0.1)

The rest of the ports on the switch are access points, and 1/2 of them are on vlan 10, and the other half on vlan 20.

I need a way for these two routers to know about each other. So I was hoping that by simply trunking FA0/1 to vlan 10 and THEN adding vlan 20 as an access port, and vice-versa with FA0/2, I'd be done.

Obviously not. I can currently ping 10.0.0.2 FROM 10.0.0.1, and vice-versa. But I cannot ping 10.1.0.2 from the switch, nor can I ping 10.1.0.1 from the switch or vice-versa.

My default gateway is 10.0.0.1, and I've put a route into that router to route 10.1/16 requests back through 10.0.0.2 (switch). Is there a way I can have a 2nd Gateway on this 2950 switch, or is there any other way I can get 1 router to know about the other one?

Here's the current config on the switch for the two trunk ports:

interface FastEthernet0/1
 switchport access vlan 20
 switchport trunk native vlan 10
 switchport mode trunk
 spanning-tree portfast disable
!
interface FastEthernet0/2
 switchport access vlan 10
 switchport trunk native vlan 20
 switchport mode trunk
 spanning-tree portfast disable

... and here's the vlans themselves:

!
interface Vlan10
 ip address 10.0.0.2 255.255.0.0
 no ip route-cache
!
interface Vlan20
 ip address 10.1.0.2 255.255.0.0
 no ip route-cache
 shutdown

Unfortunately, what's currently strange about this situation, is when I go into config t and try to turn on vlan 20 (no shut), then vlan 10 automatically shuts down and vice-versa. Not sure what that's about.

Thanks in advance.

share|improve this question
1  
The 2950 is a layer-2 only switch, and will only permit one SVI to be active at a time. Layer-3 switching requires something like a 3550, 3560, or 3750. –  James Sneeringer Oct 16 '12 at 13:42
add comment

1 Answer

up vote 1 down vote accepted

If you're configuring router on a stick then why do you have L3 interfaces defined on the switch?

If you're just looking for the 2950 to provide L2, then the configurations would properly look something like:

interface FastEthernet0/1
 switchport trunk allowed vlan 10,20
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree portfast disable

While the router interfaces would be something like

interface fastethernet0/0.10 (guessing on main iface)
   encapsulation dot1q 10
   ip address <IP in VLAN10>
interface fastethernet0/0.20
   encapsulation dot1q 20
   ip address <IP in VLAN20>

The native VLAN setup isn't really meaningful for what you've described, but the usual recommendation is that it be set to something otherwise not in use. You should be able to use the two routers as inter-VLAN gateways while simply assigning your server's ports to the appropriate VLAN with switchport host and switchport access vlan <x>

BTW - The 3810 is a very strange old beast and I recall there being some limitations as to the total number of live interfaces concurrently up in the box (among other things). It should be OK as long as you don't try to venture much past 1999 as far as features go.

share|improve this answer
    
Thanks for pointing me in the right direction. I originally misunderstood the actual point of a router on a stick, so after reading your answer, I did some research & went through a couple actual "router on a stick" guides, and decided to go with the 1 router 2 vlans option. The 2950 won't do encapsulation, so I found a 3960 in our lab equipment that did the trick. I also "upgraded" from a 2620 router to a 2650 router. Everything is working like a charm as of this afternoon! –  David W Oct 18 '12 at 23:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.