Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a FreeBSD Server and a strange problem. Everytime some tries to change a password he gets this

~$ passwd
Changing local password for <USER>
Old Password:
passwd: sorry

The root account is unaffected.

I can't find any clues in the logs. I don't use LDAP for authentification and the server is running in a jail.

share|improve this question

2 Answers 2

up vote 3 down vote accepted

The source code was so short and simple that it only took a moment to find the only place within FreeBSD's passwd utility where that particular message is printed.

Specifically, it occurs when PAM has failed to authenticate the user. In other words, one of these things:

  1. You mistyped the old password.
  2. passwd doesn't have the proper permissions; it must be setuid root.
  3. Your local PAM setup is horribly broken; if this were the case, nobody would be able to log in.

My bets are on 2.

share|improve this answer
    
Thank you for your quick answer. I can rule out 1. and 2., so it must be 3. but I can't remember changing PAM and I can log in via SSH. –  Christopher Perrin Oct 16 '12 at 18:31
    
SSH may not use PAM, depending on how it's set up. –  Michael Hampton Oct 16 '12 at 18:52
    
It is PAM ... but I can't seem to find the error –  Christopher Perrin Oct 16 '12 at 19:31

This might be a problem with NIS. Check nsswitch.conf and disable the use of NIS or YP (Yellow Pages). Then see whether the problem has gone away.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.