Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.
----------
WarningMsg
10/16/2012 2:34:05 PM
RDP disconnected!

Remote Desktop can’t connect to the remote computer for one of these reasons:

1) Remote access to the server is not enabled
2) The remote computer is turned off
3) The remote computer is not available on the network

Make sure the remote computer is turned on and connected to the network, and that remote access is enabled.
Error code 516.
----------

I've check firewall. Nothing

I did a netstat and I don't see port 3389 listed. I looked at Terminal Services and it says started but I don't have the option to restart it.

Ideas?

share|improve this question
1  
Did you do a plain netstat (listing just connections), or netstat -an (listing listening ports)? –  Philip Oct 16 '12 at 18:48
    
1. Is Remote Desktop enabled on the target computer? 2. Netstat with no options shows only current connections, you need to run netstat -a to see all listening ports and current connections. –  joeqwerty Oct 16 '12 at 18:50
    
I will try with -an and see what happens. –  Tiffany Walker Oct 16 '12 at 21:07
    
Not seeing that port with netstat -an –  Tiffany Walker Oct 18 '12 at 20:05

1 Answer 1

up vote 0 down vote accepted

Either remote desktop is not enabled on the XP machine or there is a network issue that is not allowing communication on port 3389 on the target machine. This is what you should check:

  1. Can you communicate in both directions? Ping the XP host from the W7 host. Then ping the W7 host from the HP host. If this fails, fix it.

  2. Is Remote Desktop actually enabled on the XP machine? Verify this. It's not enabled by default.

  3. Is Windows Firewall blocking RDP connections? If it's enabled, make sure inbound RDP is allowed.

  4. Do you have third party firewall/security software that would block this?

  5. Do you have a hardware firewall or router between the two devices that would block this?

Check all of these things thoroughly and you'll probably find your culprit.

share|improve this answer
    
I can ping the IP just fine. It is enabled. Nope. Nope. I do have a hardware firewall on the network. –  Tiffany Walker Oct 18 '12 at 20:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.