Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am having trouble with migrating a SVN (version 1.2.3) repo to a new server. In the process I want to update the repo and server to the latest SVN version.

I have tried dumping the repo, but found I run into a few 'malformed' revisions. Google-fu'd a bit and found a suggestion to do the dump in batches and skip the broken revisions.

Unfortunately, trying to load the dumped files is causing all sorts of issues... 1. If I try and load it directly, I receive 'non-LF' endings found errors. I try converting the line endings using notepad++ to unix format, but this doesn't seem to work. 2. I can use 'bypass-prop-validation' on the load. this works, but when I load a later dump file(revisions after the malformed ones I skipped).. it appears the skipped revisions are referenced and I am getting 'checksum mismatch' errors.

I am really after just a clear and clean way to try and upgrade and migrate the repository.

Any suggestions?

Thanks

share|improve this question
add comment

2 Answers

You might want to check the subversion repository for any outstanding transactions by means of the svnadmin lstxns command. Clean up any uncompleted transactions per pages around 502 in the free SVN book before you try another svnadmin dump.

share|improve this answer
add comment

You can use svnsync. Svnsync allows you to recreate the repositories with the advantage of using the benefits for the 1.7 version.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.