Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've got a fresh install of Remove Server 2008 R2, 64 bit. The problem is I can't Remote Destkop into it.

  1. I clicked 'Enable Remote Desktop' inside 'Initial Configuration Tasks', and set it to: Allow connections only from computers running Remote Destkop with Network Level Authentication (more secure).

The thing is, this used to work just fine, and then it stopped. The only way I can get it to work now is if I turn of Windows Firewall completely off (Public network location settings).

Obviously I don't want to run the server with firewall off, so what specific settings in Firewall do I need to disable, or am I doing something wrong?

share|improve this question
1  
have you enabled the "Remote Desktop (TCP-In)" rule in Windows Firewall with Advanced Security? –  Chris S Oct 17 '12 at 16:40
    
@ChrisS Yes it's enabled. I guess Windows does it automatically when I enabled Remote Destkop. Do I need to Add Remote Services role? –  Eternal21 Oct 17 '12 at 16:42
    
Found a workaround. Instead of using host name, I connect with IP address. What fooled me is that it used to work, but it was probably because the host name was cached in the dns server, from previous installs. –  Eternal21 Oct 17 '12 at 16:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.