Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

CentOS 5.8

I ran a yum update and MySQL updated but now it won't start. Any ideas as to what would cause this/how I can fix?

I get the following in the log:

121017 15:58:39 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
121017 15:58:40 [Note] Plugin 'FEDERATED' is disabled.
121017 15:58:40 InnoDB: The InnoDB memory heap is disabled
121017 15:58:40 InnoDB: Mutexes and rw_locks use GCC atomic builtins
121017 15:58:40 InnoDB: Compressed tables use zlib 1.2.3
121017 15:58:40 InnoDB: Using Linux native AIO
121017 15:58:40 InnoDB: Error: Linux Native AIO is not supported on tmpdir.
InnoDB: You can either move tmpdir to a file system that supports native AIO
InnoDB: or you can set innodb_use_native_aio to FALSE to avoid this message.
121017 15:58:40 InnoDB: Error: Linux Native AIO check on tmpdir returned error[22]
121017 15:58:40 InnoDB: Warning: Linux Native AIO disabled.
121017 15:58:40 InnoDB: Initializing buffer pool, size = 512.0M
121017 15:58:40 InnoDB: Completed initialization of buffer pool
121017 15:58:40 InnoDB: highest supported file format is Barracuda.
121017 15:58:41  InnoDB: Waiting for the background threads to start
121017 15:58:42 InnoDB: 1.1.8 started; log sequence number 360826692325
121017 15:58:42 [ERROR] /usr/libexec/mysqld: unknown variable 'record_buffer=2M'
121017 15:58:42 [ERROR] Aborting

121017 15:58:42  InnoDB: Starting shutdown...
121017 15:58:42  InnoDB: Shutdown completed; log sequence number 360826692325
121017 15:58:43 [Note] /usr/libexec/mysqld: Shutdown complete

121017 15:58:43 mysqld_safe mysqld from pid file /var/run/mysqld/mysqld.pid ended
share|improve this question
    
Do you have a 'record_buffer=2M' in your my.cnf file? Try removing it and seeing if that does the trick. –  Safado Oct 17 '12 at 20:07
    
i just did that. it starts now. i wonder if i need that setting... thanks. –  Nick Oct 17 '12 at 20:09
    
Alright, I posted that as the answer –  Safado Oct 17 '12 at 20:11

2 Answers 2

up vote 2 down vote accepted

Remove record_buffer=2M from your my.cnf file and try again.

share|improve this answer
    
and in response to whether you need it or not... I couldn't find record_buffer in the variables or global variables section of the MySQL docs, so maybe find out who put that config option there and find out what they were trying to do with it. –  Safado Oct 17 '12 at 20:13
    
Oh, it was there, in pre 5.5 MySQL versions. –  Alexander Janssen Oct 17 '12 at 20:41

Did you upgrade to MySQL 5.5? The variable record_buffer is deprecated.

Refer to What Is New in MySQL 5.5:

 Removed Features
 The record_buffer system variable (use read_buffer_size).

The variable is now called read_buffer_size.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.