Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Cisco 2901 with 2 internet WAN connections, one it have a static public ip, and the other one have a ftth dial connection.

I have already both configured but what i need is the following:

Currently: Internet_connection_1 (static ip) as a default route

ip route 0.0.0.0 0.0.0.0 public_ip

What i need: Use the ftth internet connection (connected in Gi0/0) to ONLY access some services, ex: clud_server_ip

How i redirect the traffic, so any who want to access Cloud_server_ip, use the ftth connection and not the adsl?

Note: i have already configured the dialer0 and getting the public ip from my isp and bonded the dialer with Gi0/0.

share|improve this question

2 Answers 2

Add a more specific route to the IP of the cloud service via the ftth interface.

So - ip route ip.of.cloud.svc 255.255.255.255 dialer0 should send traffic via the dial0 interface.

share|improve this answer
    
Thanks for your answer. I've already tryed that, and it always give timeouts, cannot reach my cloud server using static routes. –  user135131 Oct 22 '12 at 15:30
    
It may not be the dialer interface - is there a virtual template interface or similar? One interface will be kept up at all times to accept traffic to bring the dial interface itself up - it would probably be helpful if you posted some of your configuration. –  rnxrx Oct 25 '12 at 0:13
up vote 0 down vote accepted

This is the configuration that works, i hope that it can help someone else.

Here is a redirection using protocols:

ip access-list extended pbr_acl

permit tcp 192.168.0.0 0.0.255.255 any eq pop3

permit tcp 192.168.0.0 0.0.255.255 any eq smtp

permit tcp 192.168.0.0 0.0.255.255 any eq 465

permit tcp 192.168.0.0 0.0.255.255 any eq 993

permit tcp 192.168.0.0 0.0.255.255 any eq 995

permit tcp 192.168.0.0 0.0.255.255 any eq 587

permit tcp 192.168.0.0 0.0.255.255 any eq 143

route-map pbr_navigation_dial permit 10

match ip address pbr_acl

set interface Dialer0

And here the configuration using ips:

ip nat inside source list acl_dial interface Dialer0 overload

ip access-list extended acl_dial

permit ip 192.168.0.0 0.0.255.255 host x.x.x.1

permit ip 192.168.0.0 0.0.255.255 host x.x.x.2

ip route x.x.x.1 255.255.255.255 Dialer0

ip route x.x.x.2 255.255.255.255 Dialer0

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.