Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have tried the following from the command line in solaris:

 DATE TIME user@host> bash
 bash-3.2$ export http_proxy=http://localhost:8080/
 bash-3.2$ echo $http_proxy
 http://localhost:8080/
 bash-3.2$ firefox

Since I do not have a proxy running on localhost firefox should not be able to reach any website, however it acts as if no proxy is set. I looked in preferences and use system proxy settings is checked, but there is no localhost:8080 filled in. What am I doing wrong?

share|improve this question
add comment

1 Answer

Firefox won't use that environmental variable unless you first install the Environmental Proxy extension -- then it'll honor that variable just fine.

See also this quesion on AskUbuntu for more detailed information.

share|improve this answer
    
Then where does firefox get its "Use system proxy settings" from? –  user974896 Oct 18 '12 at 15:14
    
Depends on your environment. If you are running under Gnome it will get them from "gconf" (try gconf-editor and look in /system/proxy). –  chutz Oct 18 '12 at 16:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.