Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using an up-to-date Server 2008 R2 Datacenter, running IIS 7.5 and PHP 5.3.6/FastCGI

On PHP pages with lots of images (60+), some of the images fail to load

It is not always the same images-- on each page refresh an image that worked previously may not load, while an image that did not now does

Looking at the Net tab in Firebug reveals that the failing image requests are 403 errors

All of the images are located on the server in question, and the images directory has the correct permissions

I believe this problem is the result of a limit on requests

All of my attempts at researching this problem point to maxConnections setting in IIS, yet mine is set at the highest/default of 4294967295 (maxBandwidth too)

I am also running a ColdFusion site on the same IIS installation, and it does not suffer from 403's on pages with lots of images

I am left thinking that there is another connection limit (in PHP or FastCGI?) overriding the IIS connection limit

I don't see anything that looks like a request limit in the php.ini, what am I missing?

Any help would be appreciated, thank you

share|improve this question
Is it definitely 403 and not 503? If 403, do you get a 403 sub code when this happens? e.g. 403.xx – Kev Oct 18 '12 at 17:07
It's 403 with no subcode, example: HTTP/1.1 403 Forbidden Content-Type: text/html Server: Microsoft-IIS/7.5 X-Powered-By: ASP.NET Date: Thu, 18 Oct 2012 17:52:31 GMT Content-Length: 1233 – SJL Oct 18 '12 at 17:53
Are you using Dynamic IP Restriction? If you are, and it's tied down too strictly, I've gotten 403 errors in loading pages with many images. – Julie Oct 18 '12 at 19:23
Julie, it was Dynamic IP Restrictions!!! Reply with that as an Answer and I will mark it as correct – SJL Oct 18 '12 at 21:03

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.