Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We just finished deploying 2 SG300-28 switches in our network. We're building a voLANte video distribution network, so all ports were enabled to have multicasting support.

The problem we face is that our Crestron AV2 doesn't support Multicasting. Do any of you know how to disable multicasting on a single port?

Here's the running config if it matters

no spanning-tree
interface port-channel 1
description Default
exit
bridge multicast filtering
vlan database
default-vlan vlan 999
exit
vlan database
vlan 1 
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
interface range gi25-28
channel-group 1 mode on
exit
ip igmp snooping
ip igmp snooping vlan 999 
ip igmp snooping vlan 999 mrouter interface Po1 
interface vlan 999
ip igmp query-interval 30 
ip igmp last-member-query-interval 100 
exit
interface range  gi1-28
bridge multicast unregistered filtering 
exit
ip igmp snooping vlan 999 querier 
ip igmp snooping vlan 999 querier address 192.168.1.254 
interface vlan 999
ip address 10.10.10.2 255.255.255.0 
exit
ip default-gateway 10.10.10.1
interface vlan 999
no ip address dhcp 
exit
no boot host auto-config
no bonjour enable
hostname switchb18a77
no snmp-server server

It appears to me as though this would be called "Unicast and Multicast Flood Blocking"

share|improve this question
    
You're not describing what problem you're having. If your crestron doesn't support multicast, it shouldn't be joining and IGMP groups and shouldn't be receiving any multicast frames. –  smithian Oct 18 '12 at 18:59
    
the problem I'm having is that my Crestron has to run on the same network/vlan, but needs to NOT have multicasting enabled on it's specific switch port. –  Chase Florell Oct 18 '12 at 19:02
    
The crestron keeps getting locked up and loses it's connectivity. This has only begun happening since multicasting was enabled. Unfortunately, we need to run a multicast network for all our voLANte devices. –  Chase Florell Oct 18 '12 at 19:03

2 Answers 2

For future reference, I think the option you are looking for may be 'Unregistered Multicast' filtering on the SG300s. (I tried the previous answer's suggestion but that wasn't enough to help in itself for me)

I just had a Meraki router which was for some reason, subscribing to our Symantec Ghost Multicast sessions, not ideal! Setting Unregistered Multicast to Filtering for the port it was connected to sorted the issue and allowed us to get better Ghost performance too.

share|improve this answer
up vote 0 down vote accepted

Based on this link, on page 252, here are the necessary steps to disable multicast flooding on a specific port.

  1. Click Multicast > Forward All. The Forward All page opens.
  2. Define the following:
    1. VLAN ID equals to—The VLAN ID the ports/LAGs are to be displayed.
    2. Interface Type equals to—Define whether to display ports or LAGs.
  3. Click Go. The status of all ports/LAGs are displayed.
  4. Select the port/LAG that is to be defined as Forward All by using the following methods:
    1. Static—The port receives all Multicast streams.
    2. Forbidden—Ports cannot receive any Multicast streams, even if IGMP/MLD snooping designated the port to join a Multicast group.
    3. None—The port is not currently a Forward All port.
  5. Click Apply. The Running Configuration file is updated.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.