Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My client has a XenServer 6.0.2 installation with 2 Window Server 2008 R2 virtual machines.

Whenever the virtual machines are rebooted they lose their IP settings (IP address, subnet, gateway). Each time after a reboot I need to login to each VM via XenCenter and re-apply the required static IP settings.

This causes issues with connected iSCSI drives within each VM - drives need to be reconnected after each reboot.

For example, a network adapter has the following settings pre-reboot:

Description . . . . . . . . . . . : Citrix PV Ethernet Adapter #0
Physical Address. . . . . . . . . : C6-FB-A2-4F-2C-F3
IPv4 Address. . . . . . . . . . . : 10.101.0.101(Preferred) 
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 10.101.0.10
DNS Servers . . . . . . . . . . . : 10.101.0.100
NetBIOS over Tcpip. . . . . . . . : Enabled

Post-reboot:

Description . . . . . . . . . . . : Citrix PV Ethernet Adapter #0
Physical Address. . . . . . . . . : C6-FB-A2-4F-2C-F3
Autoconfiguration IPv4 Address. . : 169.254.153.174(Preferred) 
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . : 
DNS Servers . . . . . . . . . . . : 10.101.0.100
NetBIOS over Tcpip. . . . . . . . : Enabled

Under XenCenter --> Virtual Network Interfaces, each adapter is set to a static MAC address (i.e. "Use this MAC address").

I have tried the following commands within one VM but this had no effect:

netsh winsock reset catalog 
netsh int ip reset 

Can someone please help?

share|improve this question

Remove ghosted NICs

This can happen if you set your network configuration prior to installing the XenServer tools on the guest.

Open device manager on the server, and ensure you have "Show hidden devices enabled" (View menu->Show hidden devices).

If you see any additional network adapters listed, such as Realtek RTL8139 devices, remove them from device manager.

Then double-check your network adaptor is set to the correct IP address, and reboot. It should retain the IP settings you configure.

This problem occurs as the XenServer tools install a new paravirtualised network adaptor, using the same IP settings as the initially configured virtualised network adaptor (Usually a virtual Realtek NIC), without removing the settings from the old NIC. This causes an IP conflict, and the new NIC reverts to automatic configuration.

Further reading

share|improve this answer

Log in as local admin account
Open a command prompt
Issue the command set devmgr_show_nonpresent_devices=1

Launch Device Manager by typing devmgmt.msc in the same command prompt session (so the device manager session “sees” the environment variable)
In Device Manager select View -> Show hidden devices
Now the Ghosted NIC’s (RTL8139+) should be visible under Network Adapters and you should be able to just uninstall them, just by right-clicking them and select uninstall

After uninstalling the ghosted NICs, set the IP address on your nic again and it will stick.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.