Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

How can I allow an IP in webmin so I could connect to MySQL with specific user? I could do it in cPanel by adding that IP but in Virtualmin I think it's related to Host permissions or User Permissions.

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

You can certainly do this in Virtualmin, although access is generally configured on a per-domain basis.

To set it up for existing domains, do the following :

  1. Login as the master admin (root), and go to Webmin -> Servers -> MySQL Database, and click on User Permissions.

  2. Click on 'Create a new user', and add an user with the username and password for the domain, but with the hosts set to something like 192.168.0.%

  3. Go back to the main page of the MySQL module, and click on Database Permissions.

  4. Click on 'Create new database permissions', and add a record for the domain's database and user, with all permissions selected, and with the hosts set to 192.168.0.%

If you want all new domains to get acesss from 192.168.0.% by default, go to System Settings -> Server Templates -> Default Settings -> MySQL Database, and fill in the 'Allowed MySQL client hosts' field with 192.168.0.%

I admit that this is a fairly complex process, which is why I plan to add a more user-friendly single-page form for managing MySQL remote hosts to in the next Virtualmin release.

http://www.virtualmin.com/node/7825

share|improve this answer
    
+1 Thanks muhammad. –  Zim3r Oct 21 '12 at 6:29
    
You're welcome :) –  Muhammad Sholihin Oct 24 '12 at 3:15
add comment

I enabled this feature in virtualmin owner limits:

Can edit database remote hosts

and works fine.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.