Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am receiving a 500 Internal Server Error when trying to upload large files on my server. All of my PHP settings are correct, i.e. post_max_size, execution_time etc...

I am pretty certain it is a restriction with FastCGI as that is what most websites are telling me. However, all of these websites are referring to servers running Apache, and therefore the fix is simple (just edit the conf file). As I am running IIS, the problem is a little more complicated!

Does anybody have any idea how I can edit the 'MaxRequestLen' value for FastCGI in IIS? I cannot seem to find a way to do it, not helped by the fact that I am not very familiar with IIS.

If this is not the issue, then please suggest other causes of the problem uploading large files with IIS and FastCGI

share|improve this question

1 Answer 1

I just had the same problem today so I will answer it for other peeps who are going to stumble upon this.

This is caused by a value called maxContentLen being too small.

  1. On your IIS server go to start>administrative tools> IIS manager.
  2. In the IIS manager select your server and find the 'request filtering' button. It has a checkmark and a minus sign on it. Click it.
  3. On the right hand side there is 'edit feature settings', click it.
  4. Alter the 'Maximum allowed content length' value.
  5. Reboot your server

This fixed it for me. My problem was a Drupal file upload would fail with 'An AJAX HTTP request terminated abnormally' message.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.