Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I installed LAMP on Ubuntu 12.0.4 LTE. Then I installed phpmyadmin. Everything was good. I used phpadmin to do lots of DB administration....

Then I installed Zend CE server. Now, phpmyadmin throws a blank page. No login screen.

So, I reinstalled my VPS in the same sequence again. No luck. Same behavior.

This time, I installed Apache, Mysql, PHP and Zend server in that order. Then I installed phpmyadmin....Unfortunately, still blank page on phpmyadmin.

Any help?...Thanks in advance.

share|improve this question

2 Answers 2

The blank screen is likely a PHP fatal error. The best way to find out exactly what's wrong is to check the PHP error logs. I believe Zend CE server provides an interface for viewing these errors, so log into the admin and take a look in the logs area.

You also need to take a look at the requirements for PHPMyAdmin.

http://www.phpmyadmin.net/documentation/Documentation.html#require

It's possible that you haven't installed one of the require extensions in that list. Again, Zend CE server has an interface for installing extensions, so take a look at that section and enable the required extensions. You can also look at the PHPInfo area to see what's currently installed.

share|improve this answer

First, for all those that posted their suggestions to my above issue, thanks!.

Of course, I had to dig deeper into forums and threads to find the specific root cause and solution for this issue.....and after spending few hours...finally, I resolved it!. Thanks to the following bug discussion link on php.net.

https://bugs.php.net/bug.php?id=25876

I tired many suggested fixes there but they didn't help. The suggestion that finally fixed the problem was pasted below ( so that let the credit go to the right owner):


[2011-03-03 12:18 UTC] comments at htmlcompressor dot com If you are gettin the following error: "Fatal error: session_start(): Failed to initialize storage module: files (path: ) in...." Make sure that you have setup the session save path in your php.ini: session.save_path = "/tmp" which seems to be disabled by default.


I swear using Open Source software is tough!. I have spent whole day on this issue alone. My goal was to build some software and I have yet to get to it!!.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.