Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have to move my Munin instance on new server. I've installed from package (Debian) Munin 2.x. All was fine, but ... I copied /var/lib/munin to new server. But after updating munin overwrite old data and i have empty graph :( Could you tell me why? And how i can save old data?

I tried rrdtool dump/restore too. It was the same :(

Thank you for answer and help.

Br,

share|improve this question
    
Is your munin recording only for the single server? Is the hostname the same? –  EightBitTony Oct 22 '12 at 7:17
add comment

1 Answer

up vote 0 down vote accepted

What is the version of rrd databases ? The last munin want 0003 and you may need to convert them. Check with a file the version.

You may check your logs : you will maybe see something about the owner or something else.

To convert :

#!/bin/bash
SOURCE="/var/lib/munin/DOMAIN/"
cd $SOURCE
for FILE in *rrd
do 
  echo $FILE
  rrdtool dump $FILE > /tmp/$FILE.xml
  NEW=`basename $FILE .xml`
  rm $SOURCE/$NEW
  rrdtool restore /tmp/$FILE.xml $SOURCE/$NEW
  chown munin:munin $SOURCE/$NEW
done
rm /tmp/*.xml
share|improve this answer
    
How i can check rrd databases version? On old server i have 1.4.5 and on nw one i tried install the same :( –  Rafał Kamiński Oct 22 '12 at 7:13
    
Take a RRD file and do a 'file XXX.rrd' –  Dom Oct 22 '12 at 7:16
    
Old server: RRDTool DB version 0003 / That script convert rrd file? –  Rafał Kamiński Oct 22 '12 at 7:23
    
I convert copied and the same empty graph :( Any idea? –  Rafał Kamiński Oct 22 '12 at 8:38
    
Do you have check your logs ? –  Dom Oct 22 '12 at 9:13
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.