Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I Using RHEL 5 Operating System, I want updating OpenLDAP version from 2.3.x to 2.4.11 or higher, I installed OpenLDAP(v 2.3.x) based on installation package.

I have used the following command to remove OpenLDAP package first

rpm -e --allmatches openldap

but, it's failed and printed the following output:

error: Failed dependencies:
        liblber-2.3.so.0()(64bit) is needed by (installed) autofs-5.0.1-0.rc2.143.el5.x86_64
        liblber-2.3.so.0()(64bit) is needed by (installed) cyrus-sasl-2.1.22-5.el5_4.3.x86_64
        liblber-2.3.so.0()(64bit) is needed by (installed) sendmail-8.13.8-8.el5.x86_64
        liblber-2.3.so.0()(64bit) is needed by (installed) nss_ldap-253-25.el5.x86_64
        liblber-2.3.so.0()(64bit) is needed by (installed) sudo-1.7.2p1-5.el5.x86_64
        liblber-2.3.so.0()(64bit) is needed by (installed) apr-util-1.2.7-11.el5.x86_64
        liblber-2.3.so.0()(64bit) is needed by (installed) python-ldap-2.2.0-2.1.x86_64
        liblber-2.3.so.0()(64bit) is needed by (installed) subversion-1.4.2-4.el5_3.1.x86_64
        libldap-2.3.so.0()(64bit) is needed by (installed) libuser-0.54.7-2.1.el5_4.1.x86_64
        libldap-2.3.so.0()(64bit) is needed by (installed) nfs-utils-lib-1.0.8-7.6.el5.x86_64
        libldap-2.3.so.0()(64bit) is needed by (installed) gnupg-1.4.5-14.x86_64
        libldap-2.3.so.0()(64bit) is needed by (installed) cyrus-sasl-2.1.22-5.el5_4.3.x86_64
        libldap-2.3.so.0()(64bit) is needed by (installed) sendmail-8.13.8-8.el5.x86_64
        libldap-2.3.so.0()(64bit) is needed by (installed) nss_ldap-253-25.el5.x86_64
        libldap-2.3.so.0()(64bit) is needed by (installed) sudo-1.7.2p1-5.el5.x86_64
        libldap-2.3.so.0()(64bit) is needed by (installed) GConf2-2.14.0-9.el5.x86_64
        libldap-2.3.so.0()(64bit) is needed by (installed) nfs-utils-1.0.9-44.el5.x86_64
        libldap-2.3.so.0()(64bit) is needed by (installed) cups-1.3.7-18.el5.x86_64
        libldap-2.3.so.0()(64bit) is needed by (installed) apr-util-1.2.7-11.el5.x86_64
        libldap-2.3.so.0()(64bit) is needed by (installed) subversion-1.4.2-4.el5_3.1.x86_64
        libldap_r-2.3.so.0()(64bit) is needed by (installed) autofs-5.0.1-0.rc2.143.el5.x86_64
        libldap_r-2.3.so.0()(64bit) is needed by (installed) python-ldap-2.2.0-2.1.x86_64
        openldap is needed by (installed) nfs-utils-lib-1.0.8-7.6.el5.x86_64
        openldap is needed by (installed) sendmail-8.13.8-8.el5.x86_64
        openldap >= 2.1.22 is needed by (installed) python-ldap-2.2.0-2.1.x86_64
        liblber-2.3.so.0 is needed by (installed) nss_ldap-253-25.el5.i386
        liblber-2.3.so.0 is needed by (installed) apr-util-1.2.7-11.el5.i386
        liblber-2.3.so.0 is needed by (installed) subversion-1.4.2-4.el5_3.1.i386
        libldap-2.3.so.0 is needed by (installed) nss_ldap-253-25.el5.i386
        libldap-2.3.so.0 is needed by (installed) GConf2-2.14.0-9.el5.i386
        libldap-2.3.so.0 is needed by (installed) apr-util-1.2.7-11.el5.i386
        libldap-2.3.so.0 is needed by (installed) subversion-1.4.2-4.el5_3.1.i386

I worry, if I remove all dependent package it will crash my RHEL 5. Please tell me if there is a better solution for this.

share|improve this question

migrated from stackoverflow.com Oct 22 '12 at 7:13

This question came from our site for professional and enthusiast programmers.

1  
The openldap package have too many dependencies. So if you managed to remove all the dependencies, as you know, your linux box wouldn't work well. –  Taizo Ito Oct 22 '12 at 7:11
    
You either don't need to update OpenLDAP, or you probably need to update the whole operating system (e.g. to RHEL 6). Why exactly are you trying to do this? –  Michael Hampton Oct 22 '12 at 13:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.