Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a CentOS 6.3 server with 1 NIC (eth0) and an external IP (lets say 1.2.3.4). On this server I'm running a CentOS 5.6 KVM with the "default settings" (virbr0 on 192.168.122.x).

What I want to get to is having my VM "connected directly to the physical world" - as in no NAT. I have a 2nd public IP address (1.2.3.5) that has the same gateway and I also have a 2nd "real world" MAC address that I can use in combination with the address.

The problem is, I've been researching for several days on how to accomplish this the best, reading about bridging and so on, but the more I read the more confused I get.

I want my host-eth0 to remain connected on it's .4 address whilst passing .5 traffic straight to the VM. Is this possible? I've been reading about multiple MACs assigned to a single NIC, VLAN and bridging, but I have no clue where to begin.

As the server is remotely managed I'm also pretty scared of messing around with the config, because each error on my side will result in my server not being reachable. This means having to pay to get a KVM over IP hooked up to repair the damage. As I'm far from an expert in this area I would appreciate any help that I can get.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

You set up a bridge to your existing Ethernet adapter, and then configure your guests' network interfaces to use the bridge. The guests can then use any IP addresses assigned to you.

The Red Hat documentation has a step-by-step guide for setting up the bridge.

share|improve this answer
    
I've seen that page in my quest but won't adding a bridge cause the interface to loose its IP? will my host machine still be connected? (Or where do I configure it's current IP?). It does say "used for dedicating a physical device to a virtual machine" after all. –  Blizz Oct 22 '12 at 21:44
    
No, because you reassign the IP address to the bridge. –  Michael Hampton Oct 22 '12 at 21:45
    
I still had to pay for a kvm over ip (sigh)... Missed the route-eth0 file that also had to be renamed to route-br0, server went down because no default gw. Anyway your answer got me started on it finally so consider it accepted, thanks :) –  Blizz Oct 23 '12 at 10:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.