Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to connect to my VirtualBox LAMP Server with FileZilla, and it's not working. I have a static IP set, a FTP user set (with FTPd), and can connect successfully with ftp localhost, but not with Filezilla with the same credentials. I suspect this is because I am using the wrong IP address in the Host box.

so is there a command I can use to display the IP address used to connect to my FTP?

BTW, error code given in FileZilla is:

Status: Connection established, waiting for welcome message...
Response:   425 Sorry, invalid address given
Error:  Could not connect to server
share|improve this question

closed as off topic by Michael Hampton, Magellan, sysadmin1138 Oct 23 '12 at 19:39

Questions on Server Fault are expected to relate to server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

What kind of network do you use in your VM : NAT, bridge, internal, host only ? – Christophe Drevet-Droguet Oct 23 '12 at 8:02

Try starting your pure-ftd with --dontresolve option OR add it to your configuration in /etc/pure-ftpd. It's likely that your resolving had failed. Not actually the server only accepting certain IPs. By default, it will accept all incoming ftp requests regardless of IP.

share|improve this answer

As root run:

netstat -nltp

That should list all of the listening (i.e. waiting for a connection) TCP sockets and the process that holds them.

From this it should be possible to identify which addresses that the FTP server is listening on.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.