Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm install php5 by aptitude, but php release the new version and recommend we upgrade.
But I unwant to compile the new version by myself.
How to upgrade the php to the newest version by aptitude?

share|improve this question
    
Which PHP version do you currently have, and which version do you want to use? –  pkhamre Oct 23 '12 at 6:21
    
I'm using (PHP 5.3.3-1ubuntu9.10 with Suhosin-Patch) and want to use 5.3.18 which is the newest at the time of writing. –  Magic Oct 23 '12 at 8:28
1  
I suggest you update your ubuntu to 12.04 and go with the 5.3.10 provided there. Bugfixes and security issues from upstream are backported to the Ubuntu package. –  pkhamre Oct 23 '12 at 8:33
2  
You should also go through some of your questions as you have 0% accept rate, and some of the questions got proper answers. –  pkhamre Oct 23 '12 at 8:36

3 Answers 3

You can patch PHP 5.3.18 only with a modified Suhosin patch. The original one is not working. See here: http://www.itkb.ro/kb/linux/patch-suhosin-pentru-php-5318

share|improve this answer
    
For PHP 5.3.21 here is another updated patch itkb.ro/kb/linux/patch-suhosin-pentru-php-5321 –  user158647 Feb 12 '13 at 14:16

You explain that you use the php-5.3.3-1ubuntu9.10 package. I then assume that you use Ubuntu 9.10 which is an unsupported version of Ubuntu. I suggest you simply upgrade your box to the latest LTS (12.04) and use the provided package (version 5.3.10) of PHP.

share|improve this answer

You can either use a ppa like this that tries to keep up with current releases or wait till it hits the repository you are using. Or go to php and install from the rpms they offer.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.