Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

For some reason a Redmine installation keeps redirecting some https requests to http.

I'd like to change 404 response for the vhost the pages are redirected to back to the https it should have gone to. What is the syntax for that.

I am trying this link Using Nginx how do I redirect single URIs from http to https? as well, but this is the first to come to mind.

share|improve this question
add comment

1 Answer

First at all, check your Redmine's configuration:

Look at Administration > Settings > General Then Protocol.

It should be set to HTTPS and not HTTP. This is certainly your problem.

Otherwise, for nginx if you want to redirect http trafic to https:

server {
    listen       80;
    rewrite ^ https://www.example.com$request_uri? permanent;
}
server {
    listen  443 default ssl;
    server_name www.example.com;
    ...
share|improve this answer
    
The Protocol is properly set. I think it is a bug in Redmine. It only happens on certain 1. the top level project and 2. when I submit changes or create a new issue –  vfclists Oct 23 '12 at 19:08
    
Strange behaviour... I've never seen that yet ! What the logs are saying ? –  undx Oct 24 '12 at 8:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.