Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm getting this error when I try to add my windows 7 computer to the domain network called message

The W7 computer gets the IP configuration via DHCP. When I change the DNS (on the client) to it works, but I do not want to change it for every PC I have to add to the network. Something else must be wrong, but I cannot figure out what it is.

I've tried: - ipconfig /release /renew - ipconfig /flushdns - changing settings in DNS and AD

What am I missing?

share|improve this question
Make sure the DNS servers used by the client can resolve to the domain controller...try not to use routers or external DNS servers for your clients. – TheCleaner Oct 23 '12 at 15:29
Are you actually trying to join, or is that just your confusing way of trying to redact the domain you're actually trying to join? – HopelessN00b Oct 23 '12 at 15:57
Internal domain with another name I won't give for my own reasons ;) Anyway, issue is solved as you can see in the answer below. – Rob Oct 23 '12 at 16:23
up vote 5 down vote accepted

You say that you have to manually change the DNS settings on the client, and then it works correctly?

So just have DHCP hand out the correct DNS server IPs then.

If you're in a situation where you need to have your DHCP server handing out the wrong DNS server IPs but you still want to join that domain, then you either have to change the DNS settings on the clients manually, or use DHCP classes, which also involves configuration on every client.

share|improve this answer
FML, thanks. This was such a stupid mistake I could have fixed hours ago if I knew where to look. THANKS – Rob Oct 23 '12 at 14:48
Feel free to check back and mark this answer as accepted if it helps you solve your problem. :) – Ryan Ries Oct 23 '12 at 14:50
Ye, it was blocked before. It told me I had to wait 9 more minutes. – Rob Oct 23 '12 at 15:43

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.