Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I trying to deploy the latest Java RE version via GP, Java 7 update 9. I want to update computers that are currently running an older version of Java, a mixture of 7.6 and 7.7, some computers are running versions as old as 6.31. Some are running a mixture of both. I would also like this GP to install Java if it's not installed.

Previously I used push out Java updates to users machines as Java didn't remove the old version. So when it was done the user would restart their browser or pc to start using the latest version. Not the best way to manage it as it leaves the old version installed but it worked.

I've created group policies before for printer deployment, log on drive mapping scripts, but never software deployment.

I've extracted the Java MSI and created a transform file to suppress reboot etc using orca. As described on this site http://ivan.dretvic.com/2011/06/how-to-package-and-deploy-java-jre-1-6-0_26-via-group-policy/. I have also tried saving the edited MSI directly and that didn't work either.

But it just won't deploy. I have tried to enable logging as suggested on this site http://openofficetechnology.com/node/32, GPO logging via UserEnvDebugLevel, Software deployment logging via AppmgmtDebugLevel and MSI logging, but there is no log C:\Windows\Debug\UserMode\userenv.log being created.

The windows event viewer has the following errors:

Error   24/10/2012 11:44:04 AM - "Failed to apply changes to software installation settings.  Software changes could not be applied.  A previous log entry with details should exist.  The error was : %%1612"
Information 24/10/2012 11:44:04 AM - "The removal of the assignment of application Java 7 Update 9 - FB Java Transform from policy JavaDeploy succeeded."
Error   24/10/2012 11:44:04 AM - "The install of application Java 7 Update 9 - FB Java Transform from policy JavaDeploy failed.  The error was : %%1612"

There is a log created for MSI logging and it's as below. It says the source is invalid but it exists on the share and the PC that I'm testing has permissions and I've included the recommendation here Group Policy installation failed error 1274 to enable "Always wait for the network at computer startup and logon"

=== Verbose logging started: 24/10/2012  11:43:59  Build type: SHIP UNICODE 5.00.7601.00  Calling process: C:\Windows\system32\svchost.exe ===
MSI (c) (9C:EC) [11:43:59:898]: Resetting cached policy values
MSI (c) (9C:EC) [11:43:59:898]: Machine policy value 'Debug' is 3
MSI (c) (9C:EC) [11:43:59:898]: ******* RunEngine:
           ******* Product: {26a24ae4-039d-4ca4-87b4-2f83217009ff}
           ******* Action: 
           ******* CommandLine: **********
MSI (c) (9C:EC) [11:43:59:898]: Client-side and UI is none or basic: Running entire install on the server.
MSI (c) (9C:EC) [11:43:59:898]: Grabbed execution mutex.
MSI (c) (9C:EC) [11:44:03:431]: Cloaking enabled.
MSI (c) (9C:EC) [11:44:03:431]: Attempting to enable all disabled privileges before calling Install on Server
MSI (c) (9C:EC) [11:44:03:439]: Incrementing counter to disable shutdown. Counter after increment: 0
MSI (s) (2C:70) [11:44:03:574]: Running installation inside multi-package transaction {26a24ae4-039d-4ca4-87b4-2f83217009ff}
MSI (s) (2C:70) [11:44:03:574]: Grabbed execution mutex.
MSI (s) (2C:7C) [11:44:03:607]: Resetting cached policy values
MSI (s) (2C:7C) [11:44:03:607]: Machine policy value 'Debug' is 3
MSI (s) (2C:7C) [11:44:03:607]: ******* RunEngine:
           ******* Product: {26a24ae4-039d-4ca4-87b4-2f83217009ff}
           ******* Action: 
           ******* CommandLine: **********
MSI (s) (2C:7C) [11:44:03:607]: Machine policy value 'DisableUserInstalls' is 0
MSI (s) (2C:7C) [11:44:03:623]: User policy value 'SearchOrder' is 'nmu'
MSI (s) (2C:7C) [11:44:03:624]: User policy value 'DisableMedia' is 0
MSI (s) (2C:7C) [11:44:03:624]: Machine policy value 'AllowLockdownMedia' is 0
MSI (s) (2C:7C) [11:44:03:624]: SOURCEMGMT: Media enabled only if package is safe.
MSI (s) (2C:7C) [11:44:03:624]: SOURCEMGMT: Looking for sourcelist for product {26a24ae4-039d-4ca4-87b4-2f83217009ff}
MSI (s) (2C:7C) [11:44:03:624]: SOURCEMGMT: Adding {26a24ae4-039d-4ca4-87b4-2f83217009ff}; to potential sourcelist list (pcode;disk;relpath).
MSI (s) (2C:7C) [11:44:03:624]: SOURCEMGMT: Now checking product {26a24ae4-039d-4ca4-87b4-2f83217009ff}
MSI (s) (2C:7C) [11:44:03:624]: SOURCEMGMT: Media is enabled for product.
MSI (s) (2C:7C) [11:44:03:624]: SOURCEMGMT: Attempting to use LastUsedSource from source list.
MSI (s) (2C:7C) [11:44:03:624]: SOURCEMGMT: Processing net source list.
MSI (s) (2C:7C) [11:44:03:624]: SOURCEMGMT: Trying source \\server\share\deployment\Java\stable\x32\.
MSI (s) (2C:7C) [11:44:03:650]: Note: 1: 2303 2: 5 3: \\server\share\ 
MSI (s) (2C:7C) [11:44:03:650]: Note: 1: 1325 2: deployment 
MSI (s) (2C:7C) [11:44:03:650]: ConnectToSource: CreatePath/CreateFilePath failed with: -2147483648 1325 -2147483648
MSI (s) (2C:7C) [11:44:03:650]: ConnectToSource (con't): CreatePath/CreateFilePath failed with: -2147483648 -2147483648
MSI (s) (2C:7C) [11:44:03:650]: SOURCEMGMT: net source '\\server\share\deployment\Java\stable\x32\' is invalid.
MSI (s) (2C:7C) [11:44:03:650]: Note: 1: 1706 2: -2147483647 3: jre1.7.0_09.msi 
MSI (s) (2C:7C) [11:44:03:650]: SOURCEMGMT: Processing media source list.
MSI (s) (2C:7C) [11:44:04:668]: Note: 1: 2203 2:  3: -2147287037 
MSI (s) (2C:7C) [11:44:04:668]: SOURCEMGMT: Source is invalid due to missing/inaccessible package.
MSI (s) (2C:7C) [11:44:04:668]: Note: 1: 1706 2: -2147483647 3: jre1.7.0_09.msi 
MSI (s) (2C:7C) [11:44:04:668]: SOURCEMGMT: Processing URL source list.
MSI (s) (2C:7C) [11:44:04:668]: Note: 1: 1402 2: UNKNOWN\URL 3: 2 
MSI (s) (2C:7C) [11:44:04:668]: Note: 1: 1706 2: -2147483647 3: jre1.7.0_09.msi 
MSI (s) (2C:7C) [11:44:04:668]: Note: 1: 1706 2:  3: jre1.7.0_09.msi 
MSI (s) (2C:7C) [11:44:04:668]: SOURCEMGMT: Failed to resolve source
MSI (s) (2C:7C) [11:44:04:668]: MainEngineThread is returning 1612
MSI (s) (2C:70) [11:44:04:670]: User policy value 'DisableRollback' is 0
MSI (s) (2C:70) [11:44:04:670]: Machine policy value 'DisableRollback' is 0
MSI (s) (2C:70) [11:44:04:670]: Incrementing counter to disable shutdown. Counter after increment: 0
MSI (s) (2C:70) [11:44:04:670]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2 
MSI (s) (2C:70) [11:44:04:671]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2 
MSI (s) (2C:70) [11:44:04:671]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\InProgress 3: 2 
MSI (s) (2C:70) [11:44:04:671]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\InProgress 3: 2 
MSI (s) (2C:70) [11:44:04:671]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
MSI (s) (2C:70) [11:44:04:671]: Restoring environment variables
MSI (c) (9C:EC) [11:44:04:675]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
MSI (c) (9C:EC) [11:44:04:675]: MainEngineThread is returning 1612
=== Verbose logging stopped: 24/10/2012  11:44:04 ===

I'm not sure what my next approach should be. Any help would be much appreciated. Thanks.

share|improve this question
    
Check the Security event log for an audit failure? Could be permissions. –  gravyface Oct 24 '12 at 1:55
    
There are no audit failures in the security event logs –  MarcusMaximus Oct 24 '12 at 6:42

1 Answer 1

up vote 1 down vote accepted

So there was some access issue with the share. I created a new share for software deployment via group policy and gave Domain Computers access and now it's working fine.

I think there was some legacy permissions issue on the previous share location I was trying to use. I had set up a security group to test software deployment with and added the computers I was testing, I then gave permission to the deployment security group but for some reason it didn't work.

Working great now. New share only to be used for Group Policy Deployment and read access granted to Domain Computers. I think it was the sharing permissions as opposed to security permissions.

share|improve this answer
1  
Oddly enough, giving Domain Computers access fixed my problem too. I thought Authenticated Users would do it but obviously not. Thanks for the Q&A. –  Kez Oct 16 '13 at 20:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.