Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This is a recurring problem for some reason...

Using mysql 5.5, I am simply trying to create a user that can connect to the database remotely, have access to all databases, and create databases.

I have created a user using:

create user 'dev'@'%' identified by 'abcdefg';

then granted all permissions using:

GRANT ALL ON *.* to 'dev'@'192.168.%' IDENTIFIED BY 'abcdefg' WITH GRANT OPTION;

and the result is that the user cannot create databases, and can only see information_schema database for some reason.

Databases

Create database: Documentation
No Privileges

Database Ascending
information_schema
Total: 1

Does anyone know why this might be happening?

share|improve this question
    
can you create databases with the root user ? –  Elvis Oct 24 '12 at 10:58
    
and what's the content of the table mysql.db, column Create_priv for that user ? –  Elvis Oct 24 '12 at 10:59
    
already tried a flush privileges and restart ? –  Elvis Oct 24 '12 at 11:00
    
just noticed: why 'dev'@'%' ? shouldn't that be 'dev@%' or just without quotes ? –  Elvis Oct 24 '12 at 11:01
    
@Elvis Hi, root can create DBs. Dev has everything set to 'N' in the users table - thought grant all would have amended that? Have flushed and restarted service. Used 'dev'@'%' as saw it in an article and on mysql website - will use yours if you belive that to be better. very confused... cheers –  Larry B Oct 24 '12 at 11:25
add comment

1 Answer

up vote 0 down vote accepted

I think the problem might be that you're using phpmyadmin from an address that doesn't match 192.168.% ? Maybe you're connecting locally and using localhost to connect.

You can verify this by setting different passwords for 'dev'@'%' and 'dev'@'192.168.%' and see which one works through phpmyadmin.

Make sure that the user you're connecting with Combined with the correct host has the needed privileges.

share|improve this answer
    
cheers......... –  Larry B Oct 24 '12 at 14:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.