Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We are using integrated windows authentication (I think NTLM). All other clients seem to be working fine, IE6 or IE7. The intranet site is in the trusted sites zone in IE.

First user to test said IE8 originally worked, but a patch may have broken it. I tested with an upgrade of my working IE7 install to IE8 and see the same behavior.

When going to the site we get the login prompt, we can authenticate via domain\username & password. We also get prompted again when accessing something from the document library.

Has anyone else seen this behavior?

Will Sharepoint 2007 SP2 or switching to Kerberos fix it?

The below may be related, but this references running IE8 on the server, in addition, we can still authenticate, just not automatically.

share|improve this question
up vote 5 down vote accepted

Check to make sure your Trusted Sites zone allows 'Automatic login with current username and password'.

Open IE, Tools -> Internet Options -> Security -> Trusted Sites.

  1. Click 'Sites' and make sure your SharePoint site url is in there.

  2. Click 'Custom Level', scroll to the bottom and ensure 'Automatic Logon with current user name and password' is selected.

share|improve this answer
Spot on Thanks! – atom255 Jul 22 '09 at 18:46

I got the same promp in a anonymous access site, I mean, users can acces information without autentication and they try to open files then they are promted with a user name and password window.

Using IE7, Chrome or Firefox does not present that window Can anyone some idea?...

share|improve this answer

The fix of adding the site to Trusted Sites works for IE*6*.

For IE7 the equivalent is adding the site to the Intranet Security Zone.

(Note that although this seems mad as Intranet is surely a subset of Trusted, it isn't. It does work! [usually])

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.