Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I try to vim /etc/profile or vim /etc/motd it stops. When I try to touch those files it stops.

Any ideas? Nothing in the ssh logs that seems to be pertinent.

share|improve this question
up vote 3 down vote accepted

There was a similar message on the Cygwin mailing list on July 31, 2012. The solution quoted there is:

I've just applied a patch to fix this problem. It seems this is a long standing bug which could result in random stack corruption after changing or adding any file to /etc. I'm just generating a developer snapshot. Please test the today's snapshot from Just replacing /bin/cygwin1.dll with the snapshot DLL is sufficient.

So how about trying out this advice?

And seeing that you are quite active in SO, you may be interested in what seems to be the actual fix to your problem.

share|improve this answer
I tried it and it worked thanks – Roman A. Taycher Nov 2 '12 at 7:42

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.