Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Is there a way to place EXIM smtp banner on 1 line instead of 3 lines? The banner starts with 220. I've been searching but can not find a way.

under /etc/exim.conf I have

#todd host's
smtp_banner = "${primary_hostname} ESMTP Exim ${version_number} \
\#${compile_number} ${tod_full} \n\
  We do not authorize the use of this system to transport unsolicited, \n\
  and/or bulk e-mail."

do i make that one line?

share|improve this question
    
May I ask why? Have you tried removing the \n? That may be a newline. –  Zoredache Oct 25 '12 at 6:25

1 Answer 1

up vote 0 down vote accepted

The commenter above is correct, it is the "\n" which is putting newlines in your banner. Quoting the exim_docs definition of smtp_banner:

This string, which is expanded every time it is used, is output as the
initial positive response to an SMTP connection. The default setting is:

smtp_banner = $smtp_active_hostname ESMTP Exim \
  $version_number $tod_full

Failure to expand the string causes a panic error. If you want to create
a multiline response to the initial SMTP connection, use “\n” in the
string at appropriate points, but not at the end.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.