Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.
[root@sawmill sawmill]# ./sawmill
./sawmill: error while loading shared libraries: cannot open shared object file: No such file or directory

Using yum provides i found that the package which includes this file is: compat-openldap-2.3.43-2.el6.i686 . After installing it i still get the error. If i use locate, i can find the file in /usr/lib, so I tried to create a symbolic link to the file from /usr/lib to /usr/lib64 but i still get the same error. I also tried setting LD_LIBRARY_PATH=/usr/lib/ and LD_LIBRARY_PATH=/usr/lib64 but it doesn't allow me to run the sawmill installation script. Anyone knows how to solve this issue?

Edit: Installing the package you mentioned fixed the libldap file, now i'm getting stuck on the libssl file, do you know how to solve it?

[root@sawmill sawmill]# ldd sawmill =>  (0x00007fffe0cf7000) => /lib64/ (0x00007ff5fe30e000) => /lib64/ (0x00007ff5fe0f4000) => /lib64/ (0x00007ff5fdeda000) => /usr/lib64/ (0x00007ff5fdb40000) => /usr/lib64/ (0x00007ff5fd903000) => /lib64/ (0x00007ff5fd6e7000) => not found => /lib64/ (0x00007ff5fd4af000) => /usr/lib64/ (0x00007ff5fd1a9000) => /lib64/ (0x00007ff5fcf25000) => /lib64/ (0x00007ff5fcd0e000) => /lib64/ (0x00007ff5fc97e000)
        /lib64/ (0x00007ff5fe518000) => /lib64/ (0x00007ff5fc768000) => /usr/lib64/ (0x00007ff5fc559000) => /usr/lib64/ (0x00007ff5fc33f000) => not found => /usr/lib64/ (0x00007ff5fc0dc000)
[root@sawmill sawmill]#
share|improve this question

2 Answers 2

up vote 2 down vote accepted

Try running ldd /path/to/sawmill. That should show you the full path where sawmill is looking for the library.

I would probably symlink from there to wherever your package manager installed it.

Regarding the new error, you're on a 64bit OS right?

Try installing openldap-2.3.43-2.el6.x86_64 instead of openldap-2.3.43-2.el6.i686.

share|improve this answer
I've edited the question with more information, thanks for your assitance. – Itai Ganot Oct 25 '12 at 14:21

The & are part of the OpenSSL package. To install:

yum install openssl

Then re-run the command below to make sure those not found errors have been resolved:

ldd sawmill

If so, re-run your install and you should be good.

To find which library belongs to which package run:

yum whatprovides


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.