Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I need to setup radius that accept any username/password and give some attrs for mpd.

Something like: (raddb/users)

DEFAULT Framed-Protocol == PPP                                                                                    
    Service-Type = Framed-User,                                                                                   
    mpd-limit = "out#1=all shape 10240000 pass ",                                                                 
    mpd-limit += "in#1=all rate-limit 2048000 pass",                                                              
    Framed-Pool = "local"

I am not care about auth , username and other, because its backup radius, and its task accept all connections while we maintain "main" radiusd.

I tryed comment all in sites-available/default,

I tryed add DEFAULT Auth-Type = Accept

I tryed use Exec-Program-Wait = with program always return ok

But radius always return REJECT from mschap group, like that:

# Executing section authorize from file /usr/local/etc/raddb/sites-enabled/default
+- entering group authorize {...}
++[chap] returns noop
[mschap] Found MS-CHAP attributes.  Setting 'Auth-Type  = mschap'
++[mschap] returns ok
[eap] No EAP-Message, not doing EAP
++[eap] returns noop
[files] users: Matched entry DEFAULT at line 208
++[files] returns ok
Found Auth-Type = MSCHAP
# Executing group from file /usr/local/etc/raddb/sites-enabled/default
+- entering group MS-CHAP {...}
[mschap] No Cleartext-Password configured.  Cannot create LM-Password.
[mschap] No Cleartext-Password configured.  Cannot create NT-Password.
[mschap] Creating challenge hash with username: test
[mschap] Client is using MS-CHAPv2 for test, we need NT-Password
[mschap] FAILED: No NT/LM-Password.  Cannot perform authentication.
[mschap] FAILED: MS-CHAP2-Response is incorrect
++[mschap] returns reject
Failed to authenticate the user.
Login incorrect: [test] (from client localhost port 2 cli 00e05290b3e3 / 00:e0:52:90:b3:e3 / em1)
Using Post-Auth-Type REJECT
# Executing group from file /usr/local/etc/raddb/sites-enabled/default
+- entering group REJECT {...}
[attr_filter.access_reject]     expand: %{User-Name} -> test
attr_filter: Matched entry DEFAULT at line 11
++[attr_filter.access_reject] returns updated
Delaying reject of request 0 for 1 seconds
Going to the next request
Waking up in 0.9 seconds.
Sending delayed reject for request 0
Sending Access-Reject of id 175 to 127.0.0.1 port 64198
        MS-CHAP-Error = "\001E=691 R=1"

Help me please. How to set Accept for all username/pass ?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

You can set the Auth-Type attribute to accept the request:

DEFAULT Auth-Type := Accept
share|improve this answer
    
I tryed that. gist.github.com/3956774 Doesnt work –  Korjavin Ivan Oct 26 '12 at 4:01
    
Oh, sorry. Its worked, i have problem not in radius but in mpd which want MS-CHAP2-Success. I add this, and now all works –  Korjavin Ivan Oct 26 '12 at 4:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.