Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to deploy an MSI via the Group Policy in Active Directory. But these are the errors I'm getting in the System event log after logging in:

  • The assignment of application XStandard from policy install failed. The error was : %%1274
  • The removal of the assignment of application XStandard from policy install failed. The error was : %%2
  • Failed to apply changes to software installation settings. The installation of software deployed through Group Policy for this user has been delayed until the next logon because the changes must be applied before the user logon. The error was : %%1274
  • The Group Policy Client Side Extension Software Installation was unable to apply one or more settings because the changes must be processed before system startup or user logon. The system will wait for Group Policy processing to finish completely before the next startup or logon for this user, and this may result in slow startup and boot performance.

When I reboot and log in again I simply get the same messages about needing to perform the update before the next logon. I'm on a Windows Vista 32-bit laptop. I'm rather new to deploying via group policy so what other information would be helpful in determining the issue? I tried a different MSI with the same results. I'm able to install the MSI using the command line and msiexec when logged into the computer, so I know the MSI is working ok at least.

share|improve this question

8 Answers 8

up vote 35 down vote accepted

You're seeing the dreaded scourge of asynchronous policy processing. It's not a "feature" (and was default-off in Windows 2000 but default-on in Windows XP and above) and causes exactly what you're seeing-- non-deterministic behaviour with processing some types of GPO settings.

In a GPO that applies to that computer, add the following setting:

  • Computer Settings
    • Administrative Templates
      • System
        • Logon
          • Always wait for the network at computer startup and logon - Enabled

After you set that (and allow the GPO to replicate if you're in a multi-DC environment), do a "gpupdate /force /boot" on the subject PC. It will reboot and you should see the software installation occur.

The "Always wait for the network at computer startup and logon" slightly slows down the startup and logon because all GPO extensions are allowed to process, but the upside is that all GPO extensions are allowed to process.

share|improve this answer
I was running into the above error code in the original question. After applying your fix I got into the 'Error 1612. The installation source for this product is not available. Verify that the source exists and that you can access it.' It exists and I can access it. Any ideas on how to troubleshoot that? (tried gpupdate /force /boot)? Any special permission required on the distribution point? –  Unreason Aug 26 '10 at 13:54
Giving 'Domain Computers' read access to distribution point did the trick for me. –  Unreason Aug 26 '10 at 14:14
thanks. 2 tips from you, works for me –  user175128 May 24 '13 at 10:01

This can happen if the application is already installed but msiexec is unable to uninstall it. Most common scenario is a previous manual install with "Only for me" selected instead of "Everyone who logs on to this computer".

You can use the Windows Installer Cleanup Utility (http://support.microsoft.com/kb/290301) to trick the PC into thinking that the app is no longer present, and then it should come good.

share|improve this answer
Thanks for the suggestion, but upon running the utility I didn't see the app listed. I'll keep this bookmarked in the future though in case this is a solution to other problems. –  David Thomas Garcia Aug 10 '09 at 17:43

I tried the Always wait for the network at computer startup and logon - Enabled setting, but it wasn't until I added this setting below as well that allowed the software to install. Not sure if it was a combination of both settings or not. It's working now, so I'm leaving both settings.

In a Group Policy applied to these workstations, navigate to:

Computer Configuration > Policies > Administrative Templates > System > Group Policy

Enable the Startup policy processing wait time. Set Amount of time to wait (in seconds): = 120

120 might be overkill, but that worked for me. Other forums suggested setting that to 30 seconds. Even though 30 seconds default (when policy is not set), forcing it to 30 seconds worked for them.

share|improve this answer
This tip increased my deploy success from 72% to 100%. Great answer! –  Nic Dec 5 '13 at 20:54

I had the same problem but none of the fixes above worked. I finally figured out that there was another GPO trying to install software before mine, and it was failing with the %%1274 error because the GPO itself had the wrong permissions. For some reason that failure was then preventing my GPO from installing, even through mine had the correct permissions. Once I disabled the other problem GPO, my GPO installed correctly.

share|improve this answer

And I just found another different cause of this error. If you have "Spanning Tree" configured on the ethernet switch connected to the problem workstation, it will delay activation of the switch port when the PC boots up. Disabling Spanning Tree for the switch port or enabling "Spanning Tree Portfast" for the switchport solved this problem on a few of my workstations.

share|improve this answer

Changing the 'Startup policy processing wait time' worked for me. It was set to 30 seconds, but certain workstations were still failing with %%1274.

I upped it to 90 seconds and they were happy.

share|improve this answer

Sometimes your group policy can get screwed up. Try removing the entire registry key HKLM/SOFTWARE/Microsoft/Windows/CurrentVersion/Group Policy. You will probably find everything from GP gets installed again on reboot. You may want to backup your registry first...

share|improve this answer

I faced the same behavior with couple of laptops. They worked fine for couple of years, and then suddenly they didnt install any new software via gpo. Forcing the "Startup policy processing wait time" setting seem have corrected the problem. As said before it should be 30secs by default, but for me it seemed, that laptops didnt wait at all on startup for policies but skipped straight over. All laptops were win7x64, DCs Server2008R2 and Server2012.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.