Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am having squid proxy running on port 3128 with 2 nic

eth0: with internet access.

eth1: connected to LAN.

Every machines in LAN have ip in the range through DHCP.

It includes both windows and Linux machines(Ubuntu 10.04).

All the windows machines can access HTTPS pages but none of the linux machine can access https page.

When a request is made for https from linux machines,its returning webpage not available.In the squid access log no "CONNECT" request is made when accessed from Linux machine.

What can be the reason?

Squid running: on ubuntu 12.04 64 bit

squid version:squid3-3.1.19

No access restriction is made in the default squid configuration other than enabling localnet to connect.

tried setting

  export HTTP_PROXY= in bashrc 

but still not able to acces any https pages.

env https_proxy= wget --debug

 DEBUG output created by Wget 1.12 on linux-gnu.

 --2012-10-26 13:45:47--
  Connecting to connected.
  Created socket 3.
  Releasing 0x08e0a430 (new refcount 0).
  Deleting unused 0x08e0a430.

  ---request begin---
  User-Agent: Wget/1.12 (linux-gnu)

  ---request end---
  proxy responded with: [HTTP/1.0 200 Connection established

 Initiating SSL handshake.
 Handshake successful; connected socket 3 to SSL handle 0x08e0a678
  subject: /C=US/ST=California/L=Mountain View/O=Google Inc/CN=*
  issuer:  /C=US/O=Google Inc/CN=Google Internet Authority
ERROR: certificate common name `*' doesn't match requested host name     `'.
 To connect to insecurely, use `--no-check-certificate'.
 Closed 3/SSL 0x08e0a678
share|improve this question
Is this a transparent proxy or not? I am guessing not but you've got the transparent-proxy tag. Demonstrate how you are testing the connectivity. Try running env https_proxy= wget --debug on the Linux machines, and see if that gives you a hint. – chutz Oct 26 '12 at 8:20
@chutz this is not a transparent proxy – Kevin Parker Oct 26 '12 at 8:32

1 Answer 1

up vote 2 down vote accepted

Did you forget to configure the HTTPS proxy in the Linux machines?

share|improve this answer
I didnt specify anything in linux machine.but specified proxy and its port in browser. – Kevin Parker Oct 26 '12 at 8:20
Make sure you specified a proxy for the HTTPS protocol, too. – chutz Oct 26 '12 at 8:21
yep...setting that variable fixed the issue,,,thanx – Kevin Parker Oct 26 '12 at 8:34
can u tell me why i cant ping public ip even with environment varibale set in .bashrc through terminal? – Kevin Parker Oct 26 '12 at 8:39
An HTTP proxy does not let you "ping" servers. Sorry, that's how it works. You can read up on the protocol, but it is out of scope here. I don't think I can easily explain. – chutz Oct 26 '12 at 9:39

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.