Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to mount an USB flash drive formatted as w95 fat32 LBA (as reported by dmesg) under Centos. I can easily mount it using the mount command:

mount /dev/sdx1 /media/mydrive -t vfat

But it seems that the system (Centos 6.3) cannot mount it automatically. It mounts all the other filesystem types automatically. I also installed fuse-ntfs and it correctly mounts NTFS drives. How can I enable automount for vfat partiotions too? Thanks

share|improve this question
add comment

2 Answers

Add this line to the end of /etc/fstab:

/dev/sdx1 /media/mydrive vfat default 0 0

and reboot:

sudo reboot -n

defaults means use default settings, equivalent to rw,suid,dev,exec,auto,nouser,async. Read more with man fstab.

share|improve this answer
    
Don't you mean defaults? –  Michael Hampton Feb 9 at 7:55
    
This will mount the drive at boot, but I think the OP wanted it to automount when he inserts it. –  Andrew Schulman Feb 9 at 10:22
add comment

add this to /etc/fstab:

/media/mydrive    /dev/sdx1    vfat    defaults    0 0

check that all works by command

mount -a
share|improve this answer
1  
I would like to activate the automount as for other USB pen drives, so when i plugin another usb the folder is created automatically and the drive mounted. –  cpl Oct 26 '12 at 9:59
1  
check autofs, it's may help - centos.org/docs/5/html/5.1/Deployment_Guide/… –  Paul Rudnitskiy Oct 26 '12 at 12:00
    
You've reversed the first two parameters. –  Michael Hampton Feb 9 at 7:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.