Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to yum install gcc but getting this message.

Error: Package: glibc-common-2.15-37.fc17.i686 (@anaconda-0)
       Requires: glibc = 2.15-37.fc17
       Removing: glibc-2.15-37.fc17.i686 (@anaconda-0)
           glibc = 2.15-37.fc17
       Updated By: glibc-2.15-57.fc17.i686 (updates)
           glibc = 2.15-57.fc17
       Removing: glibc-2.15-56.fc17.i686 (installed)
           glibc = 2.15-56.fc17
       Updated By: glibc-2.15-57.fc17.i686 (updates)
           glibc = 2.15-57.fc17

And, if it's helpful:

uname -a
Linux laptop 3.3.4-5.fc17.i686.PAE #1 SMP Mon May 7 17:37:39 UTC 2012 i686 i686 i386 GNU/Linux

I'm not really sure how to resolve these issues.. any ideas?

share|improve this question

1 Answer 1

My guess is something's gone wrong with yum's internal cache. I'd start from a known good state:

First, connect the computer to the Internet.

Second, flush out yum's internal cache:

yum clean all

Third, apply outstanding updates:

yum upgrade

Now, try installing your program again:

yum install gcc
share|improve this answer
    
The yum upgrade failed unfortunately. I'll try removing a few packages which might be causing some problems. Thanks –  Adam Oct 26 '12 at 15:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.