Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Recently i statrted having problems with my cisco router 1811/k9, apparently was booting continually when restarted.

After i connected it to my console i found the problem while booting:


SPD Contents
8008070D 09014000 04757500 82100001 0E040C01 022000A0 75000050 3C502D20
90905050 00000000 00000000 00000000 00000000 00000000 00000000 000000A6
calculated chksum = 000000A6; stored chksum = 000000A6

DDR  Registers
timing config 1:    35331322
timing config 2:    00000800
sdram mode reg:     00000122
sdram interval reg: 02000000
sdram config reg:   C2000000
cs0_bnds reg:       00000007
cs1_bnds reg:       00F800F9
cs2_bnds reg:       0008000F
cs3_bnds reg:       00FC00FD
cs0_config reg:     80000101
cs1_config reg:     00000000
cs2_config reg:     80000101
cs3_config reg:     00000000
debug_1 reg:        40000000

DDR memory test failed.  Resetting the router ...

I tried to contact cisco TAC, but i need a re-seller contract number to place a ticket, i do not have a re-seller contract number as my router was bought more than two years ago.

I called cisco support and they told me to contact my re-seller, my re-seller told me to contact cisco so i am in a eternal loop of forwarding phone calls...

Any one have any idea on how to solve the problem ?

Any help is highly appreciated!!

Thank you guys

share|improve this question
You need to buy some new RAM. – smithian Oct 26 '12 at 12:39
Thanks smithian.. the solution was to buy new RAM – Josille Nov 11 '14 at 10:41
I have three 1812 with this error. On all three I carefully desoldered the onboard-RAM but the error persists. I tried DIMMs which run in another 1812 without any problems but fail in the defective devices. So, new RAM would not solve the problem. It's more likely some kind of RAM controller or bus fault but I'm too much a digital-hardware-noob for detailed analysis. The battery found on the boards also seems not to be the cause. On the functioning 1812 it provides the same 2,7V as on a faulty one. – user324367 Nov 26 '15 at 19:13

It seems that the DRAM cannot be replaced because the first 128MB are installed on motherboard. I would call back Cisco and try to push on their side some more. They are usually pretty good about replacing hardware issues even if there is no support purchased.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.