Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I got a clean installation of CentOS 6.3, with php 5.3.18. I tried installing the epel-release-6-7.noarch.rpm and epel-release-6-7.noarch.rpm in order to run

# yum install php-mcrypt

However it cannot find the package. Also tried

# yum install php53-mcrypt

but no luck.

Can Anyone point me on the right direction?

share|improve this question

closed as not a real question by Stefan Lasiewski, mdpc, Khaled, dunxd, Alex Feb 25 '13 at 14:25

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
And where did you get php-5.3.18? –  Michael Hampton Oct 26 '12 at 15:32
2  
Could you please post the exact error you are getting after yum command ? –  Abhijeet Kasurde Oct 26 '12 at 15:35
    
Can you post the exact error outputs? –  bmurtagh Oct 26 '12 at 17:11
    
What is the output of yum repolist? If EPEL is not listed, it's either disabled in configuration or epel-release-6-7.noarch.rpm did not install correctly. (Or, it's not reachable on the network.) –  Aaron Copley Jan 15 '13 at 17:26
    

1 Answer 1

Install the EPEL REPO via:

rpm -Uvh http://download.fedoraproject.org/pub/epel/6/i386/epel-release-6-8.noarch.rpm

#OR .../x86_64/... for 64bit

then you can

yum install php-mcrypt

(EPEL FAQ: https://fedoraproject.org/wiki/EPEL/FAQ#How_can_I_install_the_packages_from_the_EPEL_software_repository.3F )

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.