Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an apache with my vhost like:

<VirtualHost *:81>
  ServerName sandbox.myserver.com
  DocumentRoot /var/www/mysite/current/public

  <Directory />
    Options FollowSymLinks
    AllowOverride None
  </Directory>

  # Insert filter
  SetOutputFilter DEFLATE

  # Netscape 4.x has some problems...
  BrowserMatch ^Mozilla/4 gzip-only-text/html

  # Netscape 4.06-4.08 have some more problems
  BrowserMatch ^Mozilla/4\.0[678] no-gzip

  # MSIE masquerades as Netscape, but it is fine
  # BrowserMatch \bMSIE !no-gzip !gzip-only-text/html

  # NOTE: Due to a bug in mod_setenvif up to Apache 2.0.48
  # the above regex won't work. You can use the following
  # workaround to get the desired effect:
  BrowserMatch \bMSI[E] !no-gzip !gzip-only-text/html

  # Don't compress images
  SetEnvIfNoCase Request_URI \
  \.(?:gif|jpe?g|png)$ no-gzip dont-vary

  LogLevel error
  ErrorLog /var/log/apache2/vgm-error.log
  CustomLog /var/log/apache2/vgm-access.log combined

  # Turn on the rewrite engine
  RewriteEngine on


  # X-Request is for older rpm in notifications/vgm, X-Queue is for the newer gems
  RequestHeader set X-Request-Start "%t"
  RequestHeader set X-Queue-Start "%t"
</VirtualHost>

So I have a Rails project in that DocumentRoot, but when I access my Apache on port 81, I get a 503 error enter image description here

I'm really stumped and not sure what to do from here. Any help would be greatly appreciated

EDIT Results of running apache2ctl -S

VirtualHost configuration:
wildcard NameVirtualHosts and _default_ servers:
*:81                   sandbox.mysite.com (/etc/apache2/sites-enabled/mysite:1)
Syntax OK
share|improve this question
    
That.. shouldn't happen with that config. Provide the output from apachectl -S, and check the error log. But anyway, you don't have any config in place to actually serve Ruby content, you should probably start here. –  Shane Madden Oct 26 '12 at 18:13
    
The error log is blank for some reason. And I edited the post to include the results –  Shamoon Oct 26 '12 at 18:18
    
Also, I'm not sure if I"m using Passenger or not. I also have nginx on this machine, but I think it's reverse proxy'd to Apache –  Shamoon Oct 26 '12 at 18:25
    
The apache error log is completely blank? That shouldn't happen, there should at least be a message about it starting up. Are you accessing Apache directly on port 81, or proxying through nginx? You'd need Passenger config directives in your virtual host if you were running it. –  Shane Madden Oct 26 '12 at 18:30
    
The Apache error log has the startup messages. The vhost error log is completely blank. I'm accessing Apache via 81 for now before the nginx proxy. To be honest, this WAS working at some point, I'm simply trying to fix it –  Shamoon Oct 26 '12 at 18:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.