Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Trying to install ia32-libs. I run sudo apt-get install ia32-libs. The output is as follows:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ia32-libs : Depends: lib32v4l-0 (>= 0.5.0)
E: Unable to correct problems, you have held broken packages.

I have tried sudo apt-get install -f, sudo apt-get update, and sudo apt-get upgrade. I tried doing sudo apt-get install lib32v41-0, but that doesn't work either because the package cannot be found.

sudo apt-get install lib32v41-0
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package lib32v41-0

Any suggestions on how to get ia32-libs installed?

share|improve this question

1 Answer 1

ia32-libs was really just a hack to get 32 bit libs onto 64 bits as a hold over waiting for multi-arch, which we now have, making ia32-libs obsolete. You can now install i386 packages directly into and amd64 install, once you enable it.

I'm assuming that now you are on amd64. To verify, run dpkg --print-architecture and expect it to return amd64. Then you can check if i386 is listed as a foreign architecture with dpkg --print-foreign-architectures. If it is not, you can enable i386 with dpkg --add-architecture i386. Then after apt-get update, you can install a i386 version of a library by appending :i386 to the package name, for example, to install the i386 build of ncurses, you'd run apt-get install libncurses5:i386.

share|improve this answer
    
thanks for the info! –  bmurtagh Oct 26 '12 at 19:31
    
The program im trying to use isn't working properly, and they specifically said to try to install ia32-libs to get it working. But thats not possible due to the reason above. Your information is a useful alternative, but for the purpose of troubleshooting, i'd like to get ia32-libs working. –  Mitch Oct 27 '12 at 7:48
    
give us more information about why it isn't working and we can figure out which packages you need to install. ia32-libs isn't a good option for your version of ubuntu. –  stew Oct 27 '12 at 17:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.