Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have 1 application (Java) that running on my local machine (localhost:9000). I want to setup Apache as a front end proxy thus I used following configuration in the httpd.conf:

<Directory />
    #Options FollowSymLinks
    Options Indexes FollowSymLinks Includes ExecCGI
    AllowOverride All
    Order deny,allow
    Allow from all

Listen 57173

LoadModule proxy_module modules/

<VirtualHost *:9999>
  ProxyPreserveHost On
  ProxyPass /
  ProxyPassReverse /
  LogLevel debug

ServerName localhost:57173

I change my vim /private/etc/hosts to:

# Host Database
# localhost is used to configure the loopback interface
# when the system is booting.  Do not change this entry.
##       localhost broadcasthost
::1             localhost
fe80::1%lo0     localhost

and use dscacheutil -flushcache. The problem is that I can only access to localhost:57173, when I tried accessing, Chrome returns "Oops! Google Chrome could not find".
Can somebody show me where I were wrong? Thank you very much
P/S: When accessing localhost:9999 it returns The server made a boo boo.

share|improve this question

closed as off topic by Sven, Michael Hampton, HopelessN00b, EEAA, Magellan Oct 28 '12 at 5:25

Questions on Server Fault are expected to relate to server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

Please fix your hosts(5) file, i.e. move/append to line, and remove (which isn't an IP address).

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.