Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an asp.net application running on Windows 2012 in IIS 8 that has a very time consuming application start process (essentially the code running in the Application_Start() event can take up to 2 minutes). Thus I'd like to minimize the number of times the application is started so that the user can avoid a long wait.

I've enabled Preload in the application settings, and I've set the Start Mode to AlwaysRunning in the application pool. Yet the application still ends after not being used for a while, resulting in a very long time for the first visit to the website after the application shuts down.

Does anyone have any ideas on how I can prevent this?

Thanks

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

In IIS 7, you had to set the idletimeout for the apppool to "0", I would guess it's something similar for IIS 8. Details here.

share|improve this answer
    
Thanks that fixed it. I went through all the Advanced Settings in the App Pool and I can't believe I missed that. –  Lambo Jayapalan Oct 28 '12 at 20:55
add comment

I believe the AlwaysRunning option under Start Mode for the AppPool will accomplish the same thing.

http://weblogs.asp.net/britchie/archive/2010/09/08/death-to-windows-services-long-live-appfabric.aspx

Don't even think you need the appfabric on IIS8.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.