Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

For a new EC2 instance, I setup a windows server with IIS.

I added the Amazon name servers to my on my domain, and configured an elastic IP pointing to the server. I know this is working as I use this for RDC.

On the server, I added the website tied to the IP address, and used the quicklink security group that has port 80 open.

However, whenever I try going to the URL, the browser indicates that the site cannot be found.

-- Update --

Ok, I realize that wasn't much to go on, so here are some details:

  • setup Windows instance - using quicklaunch-1 security group: enter image description here
  • setup website in IIS with both www and non-www URL's to the internal IP address 10.208...
  • quicklaunch-1 security group: enter image description here
  • created a Hosted Zone in Route 53: enter image description here
  • My domain host has two slots availble for name servers - I added the .com and .org name servers here
  • When I look at the Load Balancers, I see the ...21cb Instance ID there: enter image description here
  • listeners are set to port 80
  • for this instance, I don't have the A record pointing to the load balancer - only the Windows instance's IP address
  • I can successfully RDC into the Windows server
  • when I type in the server's IP address into a browser, I get the default website (I have now disabled the default site and kept the test site in question running)

When I try to navigate to the site using Chrome Incognito mode, I get that the DNS look-up failed, otherwise, the basic 'could not find...' error message.

This application does not require a load balancer either, so as mentioned above, I have no alias set for the A record, and the value is the server's IP address (not the load balancer).

share|improve this question
3  
You'll have to be more specific as to what you "pretty much get". We are not mind readers nor can we see your screen or website. –  Michael Hampton Oct 28 '12 at 3:23

2 Answers 2

It is hard to help you if you don't define "pretty much nothing", as noted in the comment above, but it's likely that you will need to change the default security group. The default security group may be a little confusing: it appears that everything is wide open when in fact everything is closed. The default group opens all ports and protocols ONLY to computers that are members of the default group, which means that no computer across the Internet can access your EC2 instance until you change the Sec Grp settings.

In the Connection Method dropdown, open HTTP and then try to access your site again.

share|improve this answer
    
Take a look at my security group config. I've got everything open for it right now and still experiencing the same issues. –  ElHaix Oct 29 '12 at 16:07
up vote 0 down vote accepted

Hosted Zone in Route 53 records was missing a second A record that contained the www version of the domain name.

You should have two A records - one for www and another for the non-www versions of the domain name.

Once this was added it worked fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.