Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have the standalone Hyper-V Server 2012 running and I'm trying to create the first VM on it but I'm getting the following error:

enter image description here

From my research, this error comes up with something related to the Intel IPMI driver but I have an Asus motherboard so I didn't think it was the problem. However, I ran the ResetAccess.exe fix anyways and to no surprise it said something like "This version of Windows does not require this fix".

Thank you

share|improve this question
1  
Why's it creating the disk in the Public profile? –  Shane Madden Oct 28 '12 at 19:06
    
Thank you, where should I be creating the disk? I just used the default. –  Vazgen Oct 28 '12 at 21:02
    
I tried to create in C:\Users\Administrator, same error. –  Vazgen Oct 29 '12 at 1:26

2 Answers 2

up vote 3 down vote accepted

It's almost certainly due to NTFS permissions. Have you tried creating the machine somewhere other than under the C:\Users folder? Perhaps try creating a new folder and giving the Everyone group full access on it, and see if you can create a VM in there. I don't recommend you leave the permissions set like that, but this would confirm that it's a filesystem permission issue.

Does the host server have any other roles installed? Is it a domain controller, for example?

share|improve this answer
    
Ok here's what I did. Cmd.exe > md C:\TestFolder > icalcs "C:\TestFolder" /grant Everyone:(OI)(CI)F ... That fixed my problem and confirms the filesystem permission issue. Thank you. What permissions configuration do you recommend? I cannot create it on C:\Users\Administrator either.. should I change permissions on that folder or create a new folder in C:\? If so, what permission should I set? Thank you so much for the help. –  Vazgen Nov 4 '12 at 1:39
    
The host is just a core Hyper-V installation but it will host VMs for the Domain Controller and other component servers. –  Vazgen Nov 4 '12 at 1:43
    
My permissions are as follows (output using icacls "C:\Users\Administrator"): NTAUTHORITY\SYSTEM:(OI)(CI)F BUILTIN\Administrators:(OI)(CI)F MYSERVER\Administrator:(OI)(CI)F –  Vazgen Nov 4 '12 at 2:00
    
I tried to give my windows client permission to "C:\Users\Administrator" as such: icacls "C:\Users\Administrator" /grant PrimaryPC\Admin:(OI)(CI)F . This didn't work the error I got was "No mapping between account names and security ID's was done." I have a strong reason to believe this is related to a higher-level access issue I'm having here: serverfault.com/questions/445176/… –  Vazgen Nov 4 '12 at 2:08
    
Ok this is finally resolved. I need to run the following command to give Admin user permission to the folder. My set up is using WORKGROUPS so the user name and password on the server and client MUST BE THE SAME: net localgroup "Administrators" /add Admin And yes, this also resolved all 3 other access denies issues I was having on the other question I posted. Thank you very much your comment literally helped me resolved 4 different problems! –  Vazgen Nov 4 '12 at 2:20

Ok, I had a similar problem, but not exactly the same, so I'll leave my acquired knowledge here for future reference:

Something totally screwed up folder permissions on my Hyper-V Server and I started getting these same 0x80070005 Access Denied errors, when creating VM's, starting or resuming Replication, etc.

My troubleshooting method was to use SysInternals ProcMon to catch all vmms.exe activity during an operation that was giving this error. I had to do it on both Servers, Primary and Replica, to find on which one the error was actually happening.

This made me find out which files vmms.exe was actually having trouble accessing. I had a different Hyper-V server that was working fine, and I used it to compare the permission settings on that server and discover what was missing.

The problems were around two directories and their subdirectories:

c:\ProgramData\Microsoft\Windows\Hyper-V (this is a configuration directory that exists on all Hyper-V 2012 servers)

e:\hyper-V Replica (this is the directory I had setup to receive replication)

A lot of permissions that were present on the working server had mysteriously gone missing on the broken server. With the correct settings I made up this batch file to run on the broken server:

echo WARNING: back up before running this! Could damage your server and data! Make sure you know what you're doing.
echo Hit CTRL-Break to cancel.
pause
c:
cd c:\ProgramData\Microsoft\Windows\Hyper-V
icacls "InitialStore.xml" /T /grant:r "BUILTIN\Administrators":(F)
icacls "InitialStore.xml" /T /grant:r "NT AUTHORITY\SYSTEM":(F)
icacls "InitialStore.xml" /T /grant:r "NT VIRTUAL MACHINE\Virtual Machines":(R)
icacls "Planned Snapshots" /T /grant:r "BUILTIN\Administrators":(F)
icacls "Planned Snapshots" /T /grant:r "BUILTIN\Administrators":(OI)(CI)(IO)(F)
icacls "Planned Snapshots" /T /grant:r "NT AUTHORITY\SYSTEM":(F)
icacls "Planned Snapshots" /T /grant:r "NT AUTHORITY\SYSTEM":(OI)(CI)(IO)(F)
icacls "Planned Snapshots" /T /grant:r "NT VIRTUAL MACHINE\Virtual Machines":(R,WD,AD)
icacls "Planned Snapshots" /T /grant:r "NT VIRTUAL MACHINE\Virtual Machines":(CI)(IO)(GR,WD,AD)
icacls "Planned Snapshots" /T /grant:r "CREATOR OWNER":(OI)(CI)(IO)(F)
icacls "Planned Snapshots Cache" /T /grant:r "BUILTIN\Administrators":(F)
icacls "Planned Snapshots Cache" /T /grant:r "BUILTIN\Administrators":(OI)(CI)(IO)(F)
icacls "Planned Snapshots Cache" /T /grant:r "NT AUTHORITY\SYSTEM":(F)
icacls "Planned Snapshots Cache" /T /grant:r "NT AUTHORITY\SYSTEM":(OI)(CI)(IO)(F)
icacls "Planned Snapshots Cache" /T /grant:r "NT VIRTUAL MACHINE\Virtual Machines":(R,WD,AD)
icacls "Planned Snapshots Cache" /T /grant:r "NT VIRTUAL MACHINE\Virtual Machines":(CI)(IO)(GR,WD,AD)
icacls "Planned Snapshots Cache" /T /grant:r "CREATOR OWNER":(OI)(CI)(IO)(F)
icacls "Planned Virtual Machines" /T /grant:r "BUILTIN\Administrators":(F)
icacls "Planned Virtual Machines" /T /grant:r "BUILTIN\Administrators":(OI)(CI)(IO)(F)
icacls "Planned Virtual Machines" /T /grant:r "NT AUTHORITY\SYSTEM":(F)
icacls "Planned Virtual Machines" /T /grant:r "NT AUTHORITY\SYSTEM":(OI)(CI)(IO)(F)
icacls "Planned Virtual Machines" /T /grant:r "NT VIRTUAL MACHINE\Virtual Machines":(R,WD,AD)
icacls "Planned Virtual Machines" /T /grant:r "NT VIRTUAL MACHINE\Virtual Machines":(CI)(IO)(GR,WD,AD)
icacls "Planned Virtual Machines" /T /grant:r "CREATOR OWNER":(OI)(CI)(IO)(F)
icacls "Planned Virtual Machines Cache" /T /grant:r "BUILTIN\Administrators":(F)
icacls "Planned Virtual Machines Cache" /T /grant:r "BUILTIN\Administrators":(OI)(CI)(IO)(F)
icacls "Planned Virtual Machines Cache" /T /grant:r "NT AUTHORITY\SYSTEM":(F)
icacls "Planned Virtual Machines Cache" /T /grant:r "NT AUTHORITY\SYSTEM":(OI)(CI)(IO)(F)
icacls "Planned Virtual Machines Cache" /T /grant:r "NT VIRTUAL MACHINE\Virtual Machines":(R,WD,AD)
icacls "Planned Virtual Machines Cache" /T /grant:r "NT VIRTUAL MACHINE\Virtual Machines":(CI)(IO)(GR,WD,AD)
icacls "Planned Virtual Machines Cache" /T /grant:r "CREATOR OWNER":(OI)(CI)(IO)(F)
icacls "Resource Types" /T /grant:r "BUILTIN\Administrators":(F)
icacls "Resource Types" /T /grant:r "BUILTIN\Administrators":(OI)(CI)(IO)(F)
icacls "Resource Types" /T /grant:r "NT AUTHORITY\SYSTEM":(F)
icacls "Resource Types" /T /grant:r "NT AUTHORITY\SYSTEM":(OI)(CI)(IO)(F)
icacls "Resource Types" /T /grant:r "NT VIRTUAL MACHINE\Virtual Machines":(R,WD,AD)
icacls "Resource Types" /T /grant:r "NT VIRTUAL MACHINE\Virtual Machines":(CI)(IO)(GR,WD,AD)
icacls "Resource Types" /T /grant:r "CREATOR OWNER":(OI)(CI)(IO)(F)
icacls "Snapshots" /T /grant:r "BUILTIN\Administrators":(F)
icacls "Snapshots" /T /grant:r "BUILTIN\Administrators":(OI)(CI)(IO)(F)
icacls "Snapshots" /T /grant:r "NT AUTHORITY\SYSTEM":(F)
icacls "Snapshots" /T /grant:r "NT AUTHORITY\SYSTEM":(OI)(CI)(IO)(F)
icacls "Snapshots" /T /grant:r "NT VIRTUAL MACHINE\Virtual Machines":(R,WD,AD)
icacls "Snapshots" /T /grant:r "NT VIRTUAL MACHINE\Virtual Machines":(CI)(IO)(GR,WD,AD)
icacls "Snapshots" /T /grant:r "CREATOR OWNER":(OI)(CI)(IO)(F)
icacls "Snapshots Cache" /T /grant:r "BUILTIN\Administrators":(F)
icacls "Snapshots Cache" /T /grant:r "BUILTIN\Administrators":(OI)(CI)(IO)(F)
icacls "Snapshots Cache" /T /grant:r "NT AUTHORITY\SYSTEM":(F)
icacls "Snapshots Cache" /T /grant:r "NT AUTHORITY\SYSTEM":(OI)(CI)(IO)(F)
icacls "Snapshots Cache" /T /grant:r "NT VIRTUAL MACHINE\Virtual Machines":(R,WD,AD)
icacls "Snapshots Cache" /T /grant:r "NT VIRTUAL MACHINE\Virtual Machines":(CI)(IO)(GR,WD,AD)
icacls "Snapshots Cache" /T /grant:r "CREATOR OWNER":(OI)(CI)(IO)(F)
icacls "Virtual Machines" /T /grant:r "BUILTIN\Administrators":(F)
icacls "Virtual Machines" /T /grant:r "BUILTIN\Administrators":(OI)(CI)(IO)(F)
icacls "Virtual Machines" /T /grant:r "NT AUTHORITY\SYSTEM":(F)
icacls "Virtual Machines" /T /grant:r "NT AUTHORITY\SYSTEM":(OI)(CI)(IO)(F)
icacls "Virtual Machines" /T /grant:r "NT VIRTUAL MACHINE\Virtual Machines":(R,WD,AD)
icacls "Virtual Machines" /T /grant:r "NT VIRTUAL MACHINE\Virtual Machines":(CI)(IO)(GR,WD,AD)
icacls "Virtual Machines" /T /grant:r "CREATOR OWNER":(OI)(CI)(IO)(F)
icacls "Virtual Machines Cache" /T /grant:r "BUILTIN\Administrators":(F)
icacls "Virtual Machines Cache" /T /grant:r "BUILTIN\Administrators":(OI)(CI)(IO)(F)
icacls "Virtual Machines Cache" /T /grant:r "NT AUTHORITY\SYSTEM":(F)
icacls "Virtual Machines Cache" /T /grant:r "NT AUTHORITY\SYSTEM":(OI)(CI)(IO)(F)
icacls "Virtual Machines Cache" /T /grant:r "NT VIRTUAL MACHINE\Virtual Machines":(R,WD,AD)
icacls "Virtual Machines Cache" /T /grant:r "NT VIRTUAL MACHINE\Virtual Machines":(CI)(IO)(GR,WD,AD)
icacls "Virtual Machines Cache" /T /grant:r "CREATOR OWNER":(OI)(CI)(IO)(F)

(I didn't bother to check if that is all the same for all directories, maybe it is and you could just set it up with a few commands one directory level above)

I had to do something similar in my Hyper-V Replica directory for Replication to work again.

I hope this helps someone...

share|improve this answer
    
thanks for posting your experience –  Vazgen Feb 24 at 17:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.