Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to mount a device using a label in my fstab but it never actually mounts on boot.

#
LABEL=/     /           ext4    defaults,noatime  1   1
tmpfs       /dev/shm    tmpfs   defaults        0   0
devpts      /dev/pts    devpts  gid=5,mode=620  0   0
sysfs       /sys        sysfs   defaults        0   0
proc        /proc       proc    defaults        0   0
LABEL=RAID0        /ebs    auto    defaults,noatime,nobootwait        0       0
~         

However, the following does work to mount the raid array:

mount LABEL=RAID0 /ebs

Any ideas why the fstab entry does not work properly?

share|improve this question
    
Does 'mount /ebs', work? Have you tried removing "nobootwait"? –  mgorven Oct 29 '12 at 5:30
    
The nobootwait was what was causing issues. Thanks! –  VinnyD Oct 29 '12 at 5:38
add comment

1 Answer

up vote 1 down vote accepted

Try removing the "nobootwait" option. The device may not be ready when filesystems are being mounted, and this option causes the startup scripts to just ignore it and carry on.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.