Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Cisco 2950 switch which has one of its ports connected to an Internet router provided by my ISP; I have no access to the router configuration, but I manage the switch.

If I leave all switch ports with their default setup (auto-negotiation of speed and duplex mode), this link always connects at 100 MBit/s, but in half-duplex mode.

I've tried replacing the cable, and also moving the link to another switch port: the result is always the same. A different device connected to the same port (or to any switch port, really) shows no problem at all.

It could be guessed that someone configured the router to only connect in half-duplex mode... BUT, here's the catch: if I manually force the switch port to full-duplex mode (duplex full in the interface configuration), the link goes up, stays up and is completely stable.

So:

  • The connection is not forced to half-duplex mode by the router, otherwise it would not connect at all if I force the switch end to full-duplex.
  • There is no actual link problem, otherwise the full-duplex connection would not go up or would at least show some errors.
  • But if I leave the port free to auto-negotiate, it always connects in half-duplex mode.

Why?

share|improve this question
    
If I remember correctly, the guys at Stack Exchange had a very similar problem a few years ago... –  Mark Henderson Oct 29 '12 at 23:51
1  
Since you are looking at Cisco gear see this page. Basically if it is set to no-auto 100/full on one side, and auto on the other you get a duplex miss-match. –  Zoredache Oct 29 '12 at 23:56
    
Could be this situation: en.wikipedia.org/wiki/Duplex_mismatch. But I can't check the router config, and would rather not force my switch ports to 100/full... –  Massimo Oct 29 '12 at 23:56
1  
Then call the person that manages that piece of equipment and have them set it to auto. Both sides need to be auto, or both sides need to be manually configured with the correct settings. –  Zoredache Oct 29 '12 at 23:58
    
@MarkHenderson I suspect you are thinking of Fog Creek joelonsoftware.com/items/2008/01/22.html –  Zoredache Oct 30 '12 at 0:16

2 Answers 2

up vote 5 down vote accepted

The router is probably set to either full or half duplex. When one device (your router) is forced to full or half, it completely stops trying to negotiate duplex. It won't even tell the other side what it is set to.

When the other device (your switch) doesn't get a response to its negotiation attempts, it takes the default safest choice, which is half duplex.

Gigabit Ethernet solves this problem by not allowing for anything other than full duplex.

share|improve this answer
    
Then it's probably set to full, or it would become quite unhappy when I set my end to full... –  Massimo Oct 29 '12 at 23:58
    
So my only solutions are to either call my ISP and tell them to configure their router in a sane way, or to force my switch port to full-duplex (and possible run into more problems later)? –  Massimo Oct 29 '12 at 23:59
    
I've always been of the opinion that switch to switch links and switch to router links should be hard coded to a speed and duplex that both sides can operate with. –  joeqwerty Oct 30 '12 at 0:13
    
Bottom line: it only works when both sides do the same thing, otherwise it works crazily bad. Am I the only one to think this is quite less-than-ideal? –  Massimo Oct 30 '12 at 8:06

In addition to the answer longneck provided I'd like to add this blurb from a Dell document on auto-negotiation:

Communication between a non-auto-negotiation 100BaseT device and an auto-negotiation device follows these steps:

  1. The DTE powers up in link fail mode and transmits FLPs.
  2. The 100BaseTX link partner powers up and sends idle symbols.
  3. The DTE parallel detection function detects the idle symbol,bypasses the auto-negotiation function, passes control to the 100BaseTX PMA, and transmits idle.
  4. A link is established at 100 Mbps half duplex.

This image shows the possible link states:

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.