Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am a beginner with servers. I checked the error logs for Samba and it appears that Samba is timing out when I transfer large files. I can successfully add PDFs for instance to my file server. However, I tried to add a large 1.2GB video file and it did not succeed. This is the error in the log:

smbd/process.c:244(read_packet_remainder)
read_fd_with_timeout failed for client 0.0.0.0 read error = NT_STATUS_CONNECT$

Is there a way I can stop it from timing out? Any pointers would be great.

share|improve this question
    
possible duplicate of Ubuntu Server - Error adding videos/large files to file server? –  EEAA Oct 30 '12 at 3:57
    
@ErikA The Q got deleted, it's not a dupe anymore... –  Jacob Nov 2 '12 at 2:59
    
@Jacob - that q was deleted by its owner, who also happens to be the owner of this question. Deletion in bad faith, IMHO. –  EEAA Nov 2 '12 at 4:26
    
Guys, if you have something real to say, please post. I actually need help and am getting none while you just bicker about the particulars. –  phileaton Nov 2 '12 at 20:02
    
Do you observe any other errors? Did you check dmesg? –  Alexander Janssen Nov 2 '12 at 20:19

2 Answers 2

Is your client machine running Linux too? Some people report that this problem is solved by disabling opportunistic locking, which you can do by simply running the command:

echo 0 > /proc/fs/cifs/OplockEnabled

Looking at the second post reveals that the author suggests doing that immediately after loading the cifs module; in that case the correct sequence would be, after unmounting your network share:

rmmod cifs
modprobe cifs
echo 0 > /proc/fs/cifs/OplockEnabled

I wouldn't know whether it makes any difference, though.

share|improve this answer
up vote 1 down vote accepted

After weeks I finally found it. There is a line in smb.conf that sets no delay on the connection. It is by default commented out. I merely uncomment the line and voila! This is the line:

 socket options = TCP_NODELAY

it is by default commented out. If you are having an issue with this, uncomment that line in your smb.conf and restart samba.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.