Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I recently moved webserver, from a ubuntuserver set up by my brother (I have sudo) to a rasbianserver set up by my self. On the other server multiviews worked out of the box, but on the raspbian it does not seem to work althoug it seems to be enabled out of the box there as well.

What I am trying to do is to get it to find my.doma.in/mobile.php when I enter my.doma.in/mobile in the adress field.

I am using the same available-site-file as I did before, the file looks as this:

<VirtualHost *:80>
    ServerName my.doma.in
    ServerAdmin christian@doma.in

    DocumentRoot /home/christian/www/do
    <Directory />
            Options FollowSymLinks
            AllowOverride All
    </Directory>
    <Directory /home/christian/www/do>
            Options Indexes FollowSymLinks MultiViews
            AllowOverride All
            Order allow,deny
            allow from all
    </Directory>

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
            AllowOverride None
            Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
            Order allow,deny
            Allow from all
    </Directory>

    ErrorLog ${APACHE_LOG_DIR}/error.log

    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn

    CustomLog ${APACHE_LOG_DIR}/access.log combined

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
    Options Indexes MultiViews FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
    Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>

From what I have read various places while googling this issue I found that the negotiation module had to be enabled so I tried to enable it.

sudo a2enmod negotiation

Giving me this result

Module negotiation already enabled

I have read through the /etc/apache2/apache2.conf and I did not find anything in particular that seemed to be helping me there, but please do ask if you think I should post it.

Any ideas on how to solve this through getting Multiviews to work?

share|improve this question

migrated from webmasters.stackexchange.com Oct 30 '12 at 8:26

This question came from our site for pro webmasters.

1 Answer 1

up vote 1 down vote accepted

Maybe this can help: http://www.directadmin.com/forum/showthread.php?t=24683&p=126158#post126158

I've also had a similar problem before due to folder permissions on my document-root. Try setting chmod to 755 on /home/christian/www/do

share|improve this answer
    
Thank you. That solved it. –  Christian L Oct 30 '12 at 17:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.