Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have set up custom / private nameservers but I am still receiving an "Unknown host" error

$ ping ubookings.co.za

ping: cannot resolve ubookings.co.za: Unknown host

The whois query shows that the domain is registered with the relevant nameservers of ns1.uafrica.net and ns2.uafrica.net:

Whois for domain ubookings.co.za

If I query the nameserver directly using dig for that domain I get the expected response:

$ dig @ns1.uafrica.net ubookings.co.za

; <<>> DiG 9.7.3-P3 <<>> @ns1.uafrica.net ubookings.co.za ; (1 server found) ;; global options: +cmd ;; Got answer: ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 23554 ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION: ;ubookings.co.za. IN A

;; ANSWER SECTION: ubookings.co.za. 600 IN A 46.38.178.141

;; Query time: 400 msec ;; SERVER: 184.106.174.139#53(184.106.174.139) ;; WHEN: Tue Oct 30 11:48:27 2012 ;; MSG SIZE rcvd: 49

I also set up the reverse DNS on the nameservers to resolve to the host name i.e.

$ ping ns1.uafrica.net

PING ns1.uafrica.net (184.106.174.139): 56 data bytes

64 bytes from 184.106.174.139: icmp_seq=0 ttl=32 time=795.633 ms

Host lookup:

$ host 184.106.174.139

139.174.106.184.in-addr.arpa domain name pointer ns1.uafrica.net.

Finally the records ns1.uafrica.net and ns2.uafrica.net have been registered as nameservers on the domain management interface for the domain uafrica.net (which in this case is OpenSRS). This was done more than a week ago so it should not be a propagation issue.

Any guidance as to why the nameservers are not working when registering a domain would be very much appreciated (when registering the domain ubookings.co.za with these nameservers an error was received saying nameservers are not configured).

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Although ns1.uafrica.net responds for the A records, it doesn't have an answer for the NS records:

$ dig @ns1.uafrica.net ubookings.co.za NS

; <<>> DiG 9.6-ESV-R4-P3 <<>> @ns1.uafrica.net ubookings.co.za NS
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 27721
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;ubookings.co.za.       IN  NS

;; AUTHORITY SECTION:
.           600 IN  SOA ns1.uafrica.net. hostmaster.uafrica.net. 20121020 86400 3600 604800 10800

;; Query time: 99 msec
;; SERVER: 184.106.174.139#53(184.106.174.139)
;; WHEN: Tue Oct 30 10:10:02 2012
;; MSG SIZE  rcvd: 94

The parent nameservers for co.za don't know what the nameservers for ubookings.co.za are either:

$ dig co.za NS

; <<>> DiG 9.6-ESV-R4-P3 <<>> co.za NS
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 63246
;; flags: qr rd ra; QUERY: 1, ANSWER: 8, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;co.za.             IN  NS

;; ANSWER SECTION:
co.za.          2950    IN  NS  ns0.plig.net.
co.za.          2950    IN  NS  ns.coza.net.za.
co.za.          2950    IN  NS  ns0.neotel.co.za.
co.za.          2950    IN  NS  ns0.is.co.za.
co.za.          2950    IN  NS  ns4.iafrica.com.
co.za.          2950    IN  NS  ns2.coza.net.za.
co.za.          2950    IN  NS  coza1.dnsnode.net.
co.za.          2950    IN  NS  ns1.coza.net.za.

Trying one of them:

dig @ns.coza.net.za ubookings.co.za NS

; <<>> DiG 9.6-ESV-R4-P3 <<>> @ns.coza.net.za ubookings.co.za NS
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 37073
;; flags: qr aa rd; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;ubookings.co.za.       IN  NS

;; AUTHORITY SECTION:
co.za.          28800   IN  SOA ns.coza.net.za. this-is-probably-not-the-email-address-you-are-looking-for.co.za. 1121030049 28800 7200 2592000 28800

;; Query time: 186 msec
;; SERVER: 206.223.136.200#53(206.223.136.200)
;; WHEN: Tue Oct 30 10:13:19 2012
;; MSG SIZE  rcvd: 140

The problem seems to be that although the whois lists your nameservers, whois is not part of DNS and no one in the DNS hierarchy knows what your nameservers are.

Adding NS records to ns1.uafrica.net and ns2.uafrica.net would be a good start but I suspect you're missing glue as well. You will probably need to ask your registrar about that.

I highly recommend a read through of the canonical DNS question.

share|improve this answer
    
Thank you for the additional direction. It seems like the problem is related to there being no answer to the ns records. I am still trying to resolve this as I am using a wildcard setup i.e. to get the nameserver to respond the same to every request even if a specific zone has not been created. –  Andy Higgins Oct 30 '12 at 12:32
    
I think the following is my problem, which I have posted as a seperate issue: serverfault.com/questions/443684/… –  Andy Higgins Oct 30 '12 at 13:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.