Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm using Vmware ESX Server3.5 for running our Server VMs.

In one of our datastore, the partition is used 100% and Its stopping the VM to power on. /vmfs/volumes/504a6db7-97ab1f09-f958-0024818a4940 117G 117G 0 100% /vmfs/volumes/storage1

When I tried to delete the log file folder or files (17GB), I'm getting an Input/Output Error.

[root@hostos alerts]# rm -rf evtAz8721
rm: cannot remove `evtAz8721': Input/output error

I'm login as root user and the file has RW access.

Please help me to resolve this issue.

Thanks in Advance. Senthil.

share|improve this question
add comment

2 Answers 2

Use console datastore browser to remove files. It's strongly not recommended to do any actions on VMFS volumes via SSH.

share|improve this answer
    
I got this error when i tried to delete a file from Datastore browser 'General Fault Caused by file /' –  Senthil G Oct 30 '12 at 11:34
add comment

I have this same problem on an old ESX3.5 installation. The problem seems to be a full VMFS filesystem. There is some additional information about this problem in the VMware KB:

This issue occurs if the journal file is locked by one of the servers in the cluster, and there is not enough space on the device to release the lock.

To resolve this issue log into the console of each ESX server in the cluster and try to delete a file out of the VMFS volume - this operation will succeed on one of your servers, releasing the lock.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.