Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

On my Fijitsu system with intel processor, I could not ssh from my Window Vista partition using PUTTY and also could not ssh from my Ubuntu 12.04 partition.

I am try to ssh into a remote machine where I have an account but I always get Connection refused. But from the desktop computer in my office using the same PUTTY I could ssh to remote machine.

I have tried to follow several comments but none has worked for me.


Thanks to you all for the quick response ........... To Derty:

I could not ping to the server for the Window and the Ubuntu.

Here are the outputs:

  1. "dig sun.chpc.ac.za"

; <<>> DiG 9.8.1-P1 <<>> sun.chpc.ac.za
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 55409
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;sun.chpc.ac.za. IN A

;; ANSWER SECTION:

sun.chpc.ac.za. 2598 IN A 196.24.44.62

;; Query time: 1 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Tue Oct 30 21:40:35 2012
;; MSG SIZE rcvd: 48

  1. "nslookup sun.chpc.ac.za" Server: 127.0.0.1 Address: 127.0.0.1#53

Non-authoritative answer: Name: sun.chpc.ac.za Address: 196.24.44.62

After that I try to still ssh

ssh user@sun.chpc.ac.za
ssh: connect to host sun.chpc.ac.za port 22: Connection refused


In response to Safado:

I stopped the Firewire and try to ssh, yet it still connection refused


Response to Samir

When I run: "nmap sun.chpc.ac.za"

Starting Nmap 5.21 ( http://nmap.org ) at 2012-10-30 22:24 SAST Nmap scan report for sun.chpc.ac.za (196.24.44.62) Host is up (0.0044s latency). Not shown: 998 closed ports PORT STATE SERVICE 1863/tcp filtered msnp 2000/tcp filtered cisco-sccp

Nmap done: 1 IP address (1 host up) scanned in 2.81 seconds


Response to Don Simons:

Here is the output of the coommand: ssh -vvv user@sun.chpc.ac.za

OpenSSH_5.9p1 Debian-5ubuntu1, OpenSSL 1.0.1 14 Mar 2012
debug1: Reading configuration data /etc/ssh/ssh_config debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to sun.chpc.ac.za [196.24.44.62] port 22.
debug1: connect to address 196.24.44.62 port 22: Connection refused
ssh: connect to host sun.chpc.ac.za port 22: Connection refused

share|improve this question

closed as off topic by Zoredache, Michael Hampton, EEAA, Scott Pack, jscott Oct 31 '12 at 16:36

Questions on Server Fault are expected to relate to server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Please post the output of your ssh command, with "-vvv" added, ie "ssh -vvv myname@myhost", so we can see where in the connection your issue is occurring. Without any error message or debug output, any suggestions will be just guessing. It could be a firewall issue, it could be a DNS issue.... –  Don Simon Oct 30 '12 at 20:05

2 Answers 2

Check to see if the server (or a firewall in front of it) is limiting SSH access by IP address.

share|improve this answer
    
He can just use nmap from the Ubuntu partition to see if the ssh port is even open from where he is trying to connect. –  samir Oct 30 '12 at 16:51

Are you able to ping this remote maschine?

if no try to nslookup (win/ubuntu) or dig (ubuntu) this maschine and look how it resolves the IP you're trying to reach.

It could be possible that you're using the false port, normally it's 22, but if it there is a possibility to connect over the internet it should be changed to an different one.
Otherwise a dump crawler, trying to connect to whatever he founds has chances to get into this system.

Please post the dig or nslookup if it does not work.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.