Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Issue: Double logins when connecting to RemoteApps or Remote Desktop

Environment: Gateway = 1 server 2008 R2 - Roles = Gateway, Session Broker, Connection Mgr, Session Host Configuration server

Session hosts = 2 servers 2008 R2 - Roles = App Manager and Session host configuration

Testing: I can get to the url http://RDS.domain.com/rdweb - I get prompted for authentication (1) Pass authentication, get list of remote apps. Click on remoteapps or remote desktop, get prompted for authentication again (2). Pass authentication, I get access to app or RDP.

Done so far.

  • On session host Signed rdp files with cert.
  • Added the following to the custom RDP settings:

Authenticaton level:i:0 = If server authentication fails, connect to the computer without warning (Connect and don’t warn me).

prompt for credentials on client:i:1 = RDC will prompt for credentials when connecting to a server that does not support server authentication.

enablecredsspsupport:i:1 = RDP will use CredSSP, if the operating system supports CredSSP.

  • Edited the javascript file as found in http://support.microsoft.com/kb/977507
  • Added Connection ID, and added Web Access server to TS Web Access Computers group on the Session host servers, and Signed apps as found in hxxp://blogs.msdn.com/b/rds/archive/2009/08/11/introducing-web-single-sign-on-for-remoteapp-and-desktop-connections.aspx

Note: This double login happens internally and externally.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Got this straightened out.. On the Session Hosts.. In Remote Desktop Configuration... RDP-TCP Properties... Log on Settings Tab... I did not have selected "Use client-provided log on information"

Once I selected that, on each of the session hosts in the farm. no more double login

Hope this helps someone else out

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.