Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have been working on configuring multipath on a couple of RHEL 6 servers. Through some fault of my own (blacklist mistyped) I have configured multipath on the root partition, yet it seems that I am having trouble undoing that. The root partition is not on a SAN. It is a local, RAID 1 drive set.

Any help would be appreciated.

Steps taken:

Attempted to change to hard paths in fstab (sda1, etc) from UUID based paths. This brings up unbootable and in rescue mode. I didn't, however, alter the grub.conf with the same change, so I am wondering if that would do it?

Attempted to remove multipath entirely. Had to boot in rescue mode, start networking and reinstall.

Of course tried "multipath -F", but root is in use at the moment.

Haven't tried any of the above with the rescue disk, as this is a remote system and loading a cd isn't that easy, but I can manage getting it done if that is the only option.

share|improve this question

1 Answer 1

up vote 4 down vote accepted
+50

I suggest making sure your root device is explicitly excluded from multipath.conf and then rebuilding your initial ramdisk without multipath support:

dracut --force -v --omit multipath

disable multipathd with chkconfig, reboot and see if that has fixed your rootfs (and /boot etc). If it has, re-enable multipathd and restart.

share|improve this answer
    
Perfect. I had tried blacklisting the module, but I guess that doesn't really do enough to disable it. –  REW Nov 2 '12 at 18:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.